Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has been closed down.

Lexicon Omega problems (app goes crazy)

edited March 2012 in Equipment
This discussion was created from comments split from: MIDI feature requests.


  • Michael,
    Today I tried for the first time the midi implementation. I couldn't get far. Using the lexicon Omega, every time I tried adding a binding, like toggle record, the program went crazy, switching fast from loop to loop and finally crashing. I tried first using the GR20 and then the DD55 as midi controllers to send the signal into the Omega with the same results.

    I see that Midi implementation is working for others so maybe I a missing something?

    Thanks a lot for your help.

    Best, Abe
  • Oh, dear - that doesn't sound good =)
    Say... have you tried setting up bindings without having the MIDI source selected (make sure there isn't a tick beside the MIDI source in the top MIDI settings screen). It occurs to me that having it selected as a source while setting up bindings might cause trouble - I'll have to address that in an update.
  • Michael,
    Yes, I have tried that and it doesn't make any difference. This is what I think is happening, once I select the Omega as the source, even without me sending any Midi signal, Loopy acts as if it was receiving the midi order to do whatever was establish in the binding non stop.
    For example, if I bind the incoming midi signal to toggle next track, then once I select the Omega as the midi source, the track selection jumps from one track to the other non stop. If I bind it to toggle record, then it toggles record non stop, again, even without me doing anything. All I need to do is select the Omega as the midi source and it does that.
    The question is why is Loopy acting as if it was receiving a continuos flow of midi signals.

    I would be interested in knowing if anyone here has been able to successfully send midi commands to Loopy suing the Lexicon Omega.

    Do you think deleting the application and reinstalling it might help? This is a bit of a drag.

    Thanks a lot.
  • Hmm, that's really weird! Definitely haven't seen that before. I don't think deleting and reinstalling will help. Seems more likely that it's a hardware/hardware compatibility issue or something. Do you see repeated messages in MIDI Monitor? (http://iosmidi.com/apps/midi-monitor/)
  • Michael,

    I will test this tomorrow. However, according to Lexicon's Omega site, they have tested the device and it's compatible. I got this from their website:

    Q: Does the Lexicon Omega have MIDI compatibility?
    A: Yes! Not only does the Omega offer MIDI compatibility in its traditional use, but it also works with the iPad as well. We have tested our interface with the free app,
    Midi Monitor and are listed on the “Devices that Work” at www.iosmidi.com/devices.
  • Michael,

    This the answer I got from the Lexicon Omega tech support:


    We have not tested the Omega Midi with Loopy HD, we have tested it with Garage Band and it is sending midi correctly. Perhaps Loopy HD has a midi echo feature that needs to be disabled. Try contacting the software manufacturer.


    Shane Vander Veur
    Lexicon/DigiTech Support
    Phone# (801)566-8800
  • Hey @abeoquendo - There's definitely no MIDI echo feature in Loopy, but unfortunately without having one of these devices, there's not much I can do from here. I know for a fact that a bunch of other MIDI devices work just fine, so it's either something funny that your device is doing, or something funny that your iOS device is doing, or I've overlooked something =)

    I can't guarantee it'll help, but if you felt like firing up MIDI Monitor, triggering a couple of actions (just once, per action), and attaching a screenshot to this thread, it might (maybe) offer some info.
  • Michael,

    I fired Midi Monitor but there was nothing unusual about it so I don't think the screenshot will help. It just shows not on and note off after I trigger a midi command. I don't have any problems receiving midi messages nor sending midi messages to Garage Band, so whatever is going on is something particular with Loopy.
    I have also seen in the Forum that others have been successful transmitting Midi messages to Loopy, so this is a very weird and specific incompatibility. I doubt is between the Lexicon Omega and the iPad, as otherwise this will show up in Midi monitor, right? So it might be between Loopy and my iOS. I have version 4.3.5 (8L1) in my iPad. Have you had any issues with this version.
    Man, I wish this could be solved as other than this Midi issue I am having I love your software, but without the ability to toggle record via midi it's not so useful (for me) in live performances.
    Do you think it would be a good idea to create a Forum topic about this? Maybe other users have had a similar problem and have found a way to solve it.
    All the best, Abe
  • Odd indeed. I haven't heard about any issues about iOS 4.3.5, although it can never hurt to update to a recent iOS version, and can only hurt staying with an old version.

    I've split the discussion to a new thread.
  • Thank you Michael. I will update to the latest version today and report results. Hopefully that will be it.
    Best, ABe
  • My fingers are crossed =)
  • OK, I am now using version 5.1 in my iPad and the problem persists, nothing has changed.
    One thing that I should add is that once I have created the binding with the midi event, without the tick on control input, al I have to do is tick on Lexicon Omega and the "Midi Feedback Loop" starts, without me having to send any actual midi event. All I have is to turn on the control input. The funny thing is that I have no problems with the binding process.
    Anyway, I kind of give up at this point. I am really curious to learn if any other Lexicon Omega user have been able to make this work.
    Best, Abe
  • That's very, very odd. None of that code is even triggered until MIDI events come in, so if it's happening even without you triggering anything, then......... I dunno!
    Time to sell the Omega and buy something else, maybe? ;-)
  • ...Or tell Lexicon that if they do want their device to work in Loopy, then send me one ;-)
  • Michael,
    In my experience the Lexicon Omega is a good device. I have recorded a couple of albums with it with reasonable good quality and no problems whatsoever. I have also used it to score documentaries with midi, so there is no real reason for me to sell, although at some point I will need to get something bigger and better, but that something bigger and better would also not be practical for working with the iPad and Loopy.

    The whole point of working with the iPad is that is small and easily transported. So getting something small to work with Loopy is something I would consider. What would be your compatibility choice for audio and Midi with Loopy?

    Best, Abe
  • Hmm, I don't have any experience with hardware myself, but it's well worth asking others on the forum.

    I'll keep an eye out for any explanations for why the Omega doesn't work with Loopy.
  • Michael,
    I kind of figured out what's going on, I haven't fixed it, but I think I understand the problem.
    Loopy is not binding the command to the incoming Midi message but to the input device itself.
    When I click in control input Lexicon Omega and select add binding, the add new binding at the bottom of the screen is already active, so I am able to add the new binding without sending an incoming midi signal. So logically, when I then activate the Lexicon Omega as the control input device, Loopy starts repeating the action, because the input deice itself becomes the command.
    Weird but true.
    Now I don't know why loopy is binding the action to the control input device itself and not to the midi command.
    Best, Abe
  • edited March 2012
    Alright, I fixed it! Incredible. This is what I did. Since I realized that the first binding was binding the command to the controller itself (in this case the Lexicon Omega) and not to the Midi message being received by Loopy, i figured out that once the first action was bound to the Omega, I could then bind another action to a incoming midi signal. The fact that Loopy only allows a source to be bound to one action made things easier. Could the same source be bound to more than one action, then this could represent a problem for the Lexicon Omega.
    So once I had the Lexicon Omega bound to one action, I then created a second bind to an incoming Midi signal. It worked. I then proceeded to delete the first action bound to the controller itself to avoid the midi feedback loop, and activated the device as input control.
    It worked just fine, no midi feedback or stuck action command.
    Puff!! This took some figuring out!
    Best, Abe
  • edited March 2012
    deleted post
  • One last thing, and sorry if I drive you crazy, but all this might be useful for you. If you try to bind a midi message using a drum machine as a controller the program crashes. I think this happens because drum machines send an on and off message almost simultaneously and Loopy doesn't seem able to handle this.
    Best, Abe
  • edited March 2012
    deleted post
Sign In or Register to comment.