Loopy Pro - very beginning of loop missing on 1st playback

Generally I LOVE Loopy Pro. However, I'm finding that the very front end of a loop is clipped off on the first playback. From the 2nd playback it's fine (this is both when using audio threshold recording ON or OFF). Also either with onboard iPad Pro mic and also using an IRig DUO I/O interface. Any suggestions?

Comments

  • Thanks @Linsey! Hmm, that's interesting - I'd like to see how you're recording the first loop; would you mind doing a screen recording?

  • sure ...I'll do that tomorrow

  • Hi Michael, here is a screen recording and 3 screenshots to show my clip settings. Sorry, just realised that the volume is very low. Notice that on the first playback both examples have the front end clipped but on the 2nd play through and consecutive plays the complete sound is there. Is it something to do with the clip settings? When I tap on the small wave icon (that appears next to the clip) and it enlarges I can see that Loopy Pro is trying to clip the front end. How do I make sure that this does not happen. By the way, I love what you've created. I have been performing solo looping shows worldwide since 1996 and looping since 1990 and have used many many different looping pedals. I am currently using the RC505 and was about to update to mk2, but you've definitely got me reconsidering. However I am a child of the hardware age :) Here are the files: https://www.dropbox.com/sh/a503xqpo5sutbte/AABakWQbcsCN3397zWDtJfoga?dl=0

  • Apologies for the delay – catching up on some parenting time 😄 I’ll take a look at this tomorrow

  • Same for me, but with imported stems...

  • Still catching up over here, but I’ll get to this soon! @Keychee that’s very interesting! Would you mind doing a screen recording of that as well, if convenient?

  • Dear Michael,

    I have the same problem like the guys above. Especially with very shore loops e.g. like one 16th snare the first snare is missed. Only the second loop cycle is played. Any news on that problem?

  • @jogei said:
    Dear Michael,

    I have the same problem like the guys above. Especially with very shore loops e.g. like one 16th snare the first snare is missed. Only the second loop cycle is played. Any news on that problem?

    @Michael : Easy to replicate. It's pretty noticable if you make a beatbox loop with a kick on the 1, first loop that sets the tempo; the first time the loop plays back it doesn't go seamlessly from recording to playing, there's a small gap where the kick should be on the 1 the very first time the loop plays back, right after recording. The loop is on time, the length is correct, but you don't hear the 1 until the second cycle.
    My guess is its due to Loopy calculating loop length and BPM after recording?

  • edited March 20

    Oh yes, sorry to not get to this yet – what happens if you disable automatic loop detection? That may indeed introduce a small delay

  • edited March 21

    @Michael said:
    Oh yes, sorry to not get to this yet – what happens if you disable automatic loop detection? That may indeed introduce a small delay

    I'm talkin no automatic loop detection, oldschool manual punch in & out RC style :)
    But it still calculates the loop length > BPM when recording the first loop, right?
    I guess that's the actual reason why the silent skip happens, albeit shorter than when using automatic loop detection.

  • @Michael : It's quite a short gap, sounds almost like a fade-in/ envelope on the first beat after ending recording, but its long enough to cut the attack thump of a kick drum on the 1 in a non-desirable way. Its not horrible though, I could live with it. Just sayin :)

  • edited March 21

    No, all that stuff happens in a different context - there's some crafty stuff that happens straight after you stop recording where it'll immediately start playing back the start of the loop, even before it's finished writing the loop audio to disk, etc, so there should be absolutely no delay.

    I'd love to see a recording of it (with the input as well, so I can see the whole context). Could be that you're right, and it's a microfade that's responsible. But definitely something I want to improve.

    I am planning on adding a variable ramp setting, so you can configure the size of the crossfades; currently LP will do a short microfade-in to avoid discontinuities (clicks), but I'm increasingly thinking that one-size-fits-all may not do.

  • edited March 21

    @Michael said:
    No, all that stuff happens in a different context - there's some crafty stuff that happens straight after you stop recording where it'll immediately start playing back the start of the loop, even before it's finished writing the loop audio to disk, etc, so there should be absolutely no delay.

    I'd love to see a recording of it (with the input as well, so I can see the whole context). Could be that you're right, and it's a microfade that's responsible. But definitely something I want to improve.

    I am planning on adding a variable ramp setting, so you can configure the size of the crossfades; currently LP will do a short microfade-in to avoid discontinuities (clicks), but I'm increasingly thinking that one-size-fits-all may not do.

    Like I said its very easy to replicate, just record a first loop (without auto loop detection) with a sound on the 1st beat, e.g. beatbox loop with a kick on the 1, and listen to the sound of the very first playback after the loop is closed. Sounds normal on the following cycles after the first. So its not an intentional crossfade I reckon.
    I can still make a recording if necessary.

    I do think its a good idea to have control of the crossfades though :)

  • edited March 22

    Dear Michael, the error is easily replicateable.

    • activate threshold recording in clip menu
    • Put your headphones on
    • enabling threshold recording by pushing one looper (circle button) on the iPad
    • snap your finger or play a beat / snare on a drum machine - the looper starts recording the snap / drum beat / snare
    • Wait 5 seconds or any other time
    • Push the looper (circle button ) again - the looper goes into play mode

    I would expect that the looper plays the snap / beat / snare immediately - but it doesn’t. Sometimes it takes a full cycle of the loop, sometimes only a fraction of the recorded audio (beat, snare, snap) is played (but rather distorted).

  • Hi Michael I am having the same problem as the others and it’s so frustrating because if just doesn’t sound right for my ambient kind of music
    I’m playing a ukulele plugged into my audio interface straight into my iPad Pro 2017
    I have turned on and off everything I can think of
    I need to have audio detection on or I can’t play the Uke and press record (need that third arm lol)
    Can you please advise if this is something you can fix or I can change a setting that maybe I missed ?
    Thank you so much

  • I may have stumbled upon an answer
    If you go into the loop
    Go to custom playback quantization
    When I did it said 1 bar. I moved it all the way to the left and now it says 1/16 beat
    And it seems to be playing back from the beginning !!
    Let me know if this works for anyone else
    And Michael is that it? Lol

  • @sleepingangelmusic: this is not a solution - there is a bug in the software that has been mentioned by many users and is easy to replicate (see my comments above). Even in the discord support group this bug has been mentioned many times.

    Michael, could you please comment if there is a plan to fix this in the next release?

  • @Michael do you have any input here? :)

  • edited April 8

    Apologies for the delay! I have this one fixed in the upcoming version 1.0.7, coming in the next few days.

  • @Michael said:
    Apologies for the delay! I have this one fixed in the upcoming version 1.0.7, coming in the next few days.

    Fantastic!

  • Hi Michael, thanks for providing a bugfix. It works great now with fluent playback of the initial loop :) <3 The looping experience has improved greatly!!!! Best Joachim

Sign In or Register to comment.