Crackles, MIDI Clock issues

edited July 2013 in General

Hi all,
I'm experiencing a variety of problems which might be caused by Loopy HD, or iOS6 or the Alesis iODock. Over time, Loopy seems to struggle with incoming MIDI Clock - loops start to drop sync. I also experience crackles in the audio. Both issues disappear if I reload Loopy, but gradually re-emerge.
I'm not doing anything fancy. Basic loops, just 2 or 3 loops per session, no overdubs. The loops are typically 8 bars in duration. iPad2, set to Airplane mode, all networking and bluetooth switched off, no additional apps running, no audiobus. So the only app running on the iPad is Loopy HD, slaved to MIDI Clock from an Alesis Performance Pad Pro.

The VoiceLive Touch 2 receives the same MIDI clock (downstream from Loopy), but it doesnt lose sync over time. It really seems to be Loopy HD struggling to keep its loops in sync over a period of (say) 5 minutes.

The crackles are really annoying and inappropriate for a gig situation, and losing sync at a gig is also unacceptable, so I'm now considering replacing Loopy HD with the Roland RC-505 Loop Station. So my "loop rig" would be RC-505 Loop Station plus VoiceLive Touch 2.

But I really like Loopy, so my question is really this: Are the problems I'm encountering related to Loopy, or the iODock, or something mysterious?

Thanks!

Comments

  • Latest firmware on the IO dock?

  • edited July 2013

    Yep.

    I should also add that the time period of problem-free playback is variable - sometimes it takes 10 or 15 mins for things to crumble. I suspect the iODock is causing the crackles, but I think the sync thing might be Loopy (or iOS), because the sync between loops in Loopy seems to struggle (and deteriorate) some time before the sync breaks up between the main/first loop and the external device providing the MIDI Clock.

  • edited July 2013

    Using a dock extender cable? I have had 2 bad cables which have produced a similar crackling/static.

    I have been struggling with a similar issue too for quite some time but am using a different interface. I am also using a midi foot controller and Fishman Triple play via a USB hub so my setup is increasingly complicated. It seemed like it was just me though so I had given up the thought that it might be Loopy. The only thing that has worked for me is in the Midibridge app I block all midi messages from almost all of my devices except for those that are absolutely necessary to keep things running. It works way better, but only for a while and then the static will start to creep back in so I have to unplug the dock connector and reconnect and then it will work for awhile again.

    Sometimes I notice when the issue starts getting bad, I will record engage a track but when the loop starts playing back it is like a 1/2 beat off or more from the punch in. It is frustrating to say the least but I have gotten by. Would love to get a hard resolution to what is causing this issue but for now I am sick of troubleshooting and want to make music!

    http://forum.loopyapp.com/discussion/843/loopy-issue-or-something-else#Item_9

  • Also wanted to thank you for posting that you are having this type of issue with an iPad 2. For a while there was a theory floating around that the iPad 3 had some sort of inherent issue with audio/midi processing. So if your issue turns out to be related to mine, I can remove that theory from the troubleshooting checklist.

  • I've noticed that Loopy HD frequently barfs on incoming MIDI Clock sync when replaying loops, but I might be wrong about the underlying cause or circumstances. Maybe it's just that Loopy still has some bugs to iron out when synching multiple loops to external MIDI Clock.

    And therein lies the rub for me: Loopy is great fun to use, but it doesnt seem ready yet for live gigs involving an external MIDI Clock as master, with Loopy as a slave. The sync dropouts seem to occur when Loopy is synchronizing loops within Loopy, but it occurs more often when sync is external and Loopy isnt master.

    I perform live roots music, with other musicians in my band also running loop stations. We dont like using pre-prepared beats/loops and prefer to create everything on the fly in real time. We construct/deconstruct with minimalism as the main game. We need solid sync and good punch-in/punch out.

    Although we all love Loopy, it's looking more like we'll invest in a Boss RC-505 as the main loop station, with each of us also running a VoiceLive Touch 2. The Boss RC-505 will provide MIDI Clock.

    VLT2 allows each of us to work without foldback wedges - we use the headphone output for in-ear monitoring (metronome in headphone only) and the stereo RoomSense mics allow us to add in as much of the gig sound as we want. Between that and the excellent flexibility from the Mackie DL1608 mixer (which can be controlled by multiple iPads/iPhones) we derive very flexible in-ear foldback.

    I cant see us deriving the same power and reliability from Loopy. Not yet, anyway...

  • edited August 2013

    Found this too:

    http://forum.loopyapp.com/discussion/comment/1175#Comment_1175

    Different interface, seemingly same problem. Man I wish it could be figured out what causes this. I mean, it is obviously MIDI clock related, but why does it happen right away sometimes vs. 10-20 mins in. Last night I was experimenting again and noticed that the issue would start up when switching apps in the forefront. Could it be tied to that somehow?

  • I sometimes get crackles, sometimes not, after about 20-30 minutes of use. I use Loopy in my band and before each jam I do the following to ensure Loopy is the only app running on my iPad 3 (audio gets in and out of the iPad via a Zoom G3X and CCK):

    1. Put the iPad into Airplane mode
    2. Hard restart (hold home and power button for 7 seconds)
    3. Load up Loopy on restart.

    Even with this routine I can still get crackling. A restart of the iPad fixes the crackling. My setup is as follows:

    • Rocktron Midimate > generic USB/MIDI cable > Powered USB Hub port 1
    • Zoom G3X > Powered USB Hub port 2
    • Powered USB Hub output > CCK > iPad running Loopy
  • I had also this issue using this setup :
    -hub usb
    -novation x-station 49
    -Alesis IO4
    -Ipad 3

    I've been abble to reduce this problem using just one USB device directly with CCK and Alesis IO4.
    Using Novation X-station + CCK + Ipad, I can manage both midi + audio, and works quite good. At the moment I had just a crash, a kind of pink noise into loopy, but it seems it was the x-staton crashing...I'll make further tests if I may reproduce.

    I also using midibridge. Maybe these problems are gone with an Ipad 4 ? Does anyone using an Ipad 4 ?

  • I do use an ipad 4. same here, neither solution: midibridge, modrum, wired and wifi network session sync works. This pretty much sums it up for me: http://papernoize.tumblr.com/post/65428983842/one-year-with-the-ipad-the-ipad-as-a-multi-track

    I just ordered the electroharmonix 45000 looper.

  • pitty, it's way inferior to loopy of course. So hey, michael, If you create a nice piece of hardware that runs loopy and does reliable midi clock sync as master and slave, it would beat ehx 45000, boss RC-505 and all the other midi-sync capable loopers out there...

  • … just because from what I gather it's not loopy's fault but midi on ios is a real mess, right?

  • I'm very sorry to hear of the trouble you guys're having with MIDI - I'm afraid it appears to be notoriously tricky to get it working perfectly right now. I hear the same thing from my colleagues with their users sometimes. I've not been able to pin down where the issue lies just yet - I've been thinking about building a diagnostic system in, but I'm afraid that's going to take a big chunk of time to make.

    This may also be the kind of problem that spontaneously vanishes with an OS update.

  • Michael, thanks for checking back, I'll stay on it, let's hope a future OS update will do the trick. And yes, even Modrum, which I tried to sync loopy to since its midi sync/clock stability gets a lot of praise has a sync hickup eventually...

  • I also get crackling and audio abnormalities, but only with the Behringer iSTUDIO dock or after using other apps with Audiobus. (ex. running IK's SampleTank) . Sometimes reloading Loopy fixes this issue, other times a restart of the Springboard is needed.

  • I'm not sure it's 'just' loopy's fault.

    I get clicks too at times. I think it's my iPad(3) not being able to cope with the processes. I had loopy running w audiobus, system mic on input and liveFX as FX. I got a weird clicky thing with only one loop. so I closed audiobus, and liveFX, ran only loopy (same session) and there was no crackling on new loops via system mic input, i tried to distort it too, that was a different type of 'noise'.

    I tested further and found that my ipad doesn't like the tape echo on liveFX (just liveFX running nothing else). Even just singing one note and then dragging the tapeEcho produces mad crackling.

    Previously I had crackles with just loopy and my zoomH4 via CCK, by loop #4 it was crackling, I thought it was a level accumulation thing at first as it was a bit rhythmic.

    I dunno, shame though. Really want to use my iPad as a perf tool.

  • I was running Loopy on an iPad2 with the Alesis IO Dock (the first model) and I always had a lot of issues. My theory is that it just doesn't handle MIDI clock well, if you use it as a clock master it works fine.
    My theory is the following: Loopy re-renders the loop if it detects a tempo change, as long as the loop is not rendered you get a low-res preview version of the loop, MIDI clock is not smoothed or averaged and a change of 1BPM in the received clock is triggering the time stretching and hence the re-rendering of the loop.
    Now the iPad is not the best in handling MIDI sync from external sources, I've tried many different interfaces and I always had problems, it will always jitter a bit. So I think this continuos re-rendering of the loop is what causes the glitches.
    It could maybe be solved by using some smoothing/averaging on the incoming MIDI clock and maybe raise the threshold at which the loop gets re-rendered.

    I stopped investigating the problem though since I'm now an extremely happy and satisfied owner of an RC-505. If you ask me, there's nothing like a dedicated bit of hardware if you're doing a lot of live looping and the RC-505 is really the best looper I've seen so far (well except for the lousy on-board FX).

  • This issue is not specific to Loopy nor is is necessarily due to Midi Clock.

    I'm on this forum not because I'm running loopy, but because I'm investigating whether I should try it out on a couple of funk songs my band wants to play.

    Unfortunately, I've already been experiencing the "Crackling" issue with SampleTank/SetListMaker/iPad2 on iOS6/iOdock. I've been told that this occurs when the iPad's processor runs out of resources and begins to glitch. It is less than encouraging to see iPad4 owners struggling with similar issues.

    My solution for Sampletank looks like it must be a $2000 product. (Only the Roland Integra-7 allows similar editing of patches on iPad using a hardware rack mount synth.) Depressingly, this thread suggests I should give loopy's awesome, flexible user interface a miss and instead shell out another $600 for an EHX 45000.

    It seems the iPad's meteoric rise to fame as a live musician's best friend has outstripped its own resources in only a few years. For me, it's back to embedded devices while I leave the iPad to handle my set list. Toys will be toys.

  • i´m working with an ipad air for nearly 3 months and did not notice any crackles or midi-clock issues. i also work with 3 boss-loopers, rc 50, rc 300, rc 505.
    no bad experiences with the ipad, loopy, sampletank etc. so far and i don´t think it is a toy.

  • @owi - do you use your iPad for live shows? If you do, is any of your setup required to sync with other players?

    Do you run Loopy as master or slave?

    Refer my two recent posts here:

    http://forum.loopyapp.com/discussion/2361/loopy-hd-1-4-10loopy-2-5-10-update#Item_7

    Live performances require sync to be very reliable.

  • edited September 2014

    From papernoise's post above:
    My theory is the following: Loopy re-renders the loop if it detects a tempo change, as long as the loop is not rendered you get a low-res preview version of the loop, MIDI clock is not smoothed or averaged and a change of 1BPM in the received clock is triggering the time stretching and hence the re-rendering of the loop. Now the iPad is not the best in handling MIDI sync from external sources, I've tried many different interfaces and I always had problems, it will always jitter a bit. So I think this continuos re-rendering of the loop is what causes the glitches. It could maybe be solved by using some smoothing/averaging on the incoming MIDI clock and maybe raise the threshold at which the loop gets re-rendered.

    ===========

    I don't know if papernoise's theory is correct, but intuitively it seems to make sense. My experience with 2.5.10 certainly fits that explanation. External sync works a lot better than earlier iterations, but one or more loops sometimes drop out of sync in a manner which seems random. That said, I've also noticed the same phenomenon occurring when using Clear (via MIDI) while multiple loops are playing.

    I've reduced the possibility of it being resource/buffer related by having Loopy be the only app running on the iPad and using a buffer of 512.

    It's worth noting the VLT2 does not lose sync between loops when using the same clock source as Loopy, which implies that it can be done.

    @michael: it seems your work on MIDI has been mostly successful so far, but needs further tweaking? If you can manage it, live performers who really need stable MIDI sync will be able to incorporate Loopy into live systems.

  • I'd love to get this 100% solid. Stay tuned, i'll be in touch when I'm doing the next update (soonish), as I'd love to get some testing with your setups (as I can't make Loopy hiccup at all with my setup, for some reason).

  • I've been beta testing pro audio apps since 1997, so I'm happy to assist in any way you require. Between my other band members and I we have an iPad 2, two x iPad3 and an iPad 4, all running iOS 7.1.2. Devices relying on MIDI include One x RC-505, Three x VLT2, iConnectMIDI4+, iConnectMIDI2+, Griffin StudioConnect, Alesis IODock, MIDI Solutions Quadra Thru, Two x FCB1010 plus assorted instrument MIDI controllers etc.
    Mixer = Behringer X32 Rack (wickedly good!).

    The RC-505 is the master device which we use for acoustic drums/percussion loops. Now we each need to expand our individual loopstation capabilities beyond the VLT2 by either buying another three x RC-505 units, or return to using Loopy. We had to abandon Loopy a year ago because of sync issues but we really hope to use Loopy again some day soon once the final sync optimizations are achieved. Hope is good!

  • Okay, cheers @Diggo, I'll send you an invite to TestFlight once I'm up and running again.

  • The clicking, static and popping are making Loopy unusable for me. its so sad. Please let me know when a fix is available. ipad2 on a focusrite idock using a KM softstep for triggering.

  • @2Jindo said:
    The clicking, static and popping are making Loopy unusable for me. its so sad. Please let me know when a fix is available. ipad2 on a focusrite idock using a KM softstep for triggering.

    Are you using Loopy in standalone or hosted? Are there any other apps involved?

  • I'm a bit worried your device is just a bit too old, @2Jindo - iPad 2 is nearly ten years old now, and really not very capable of a great deal, especially on the latest iOS version that it can run. These things really do seem to get slower and less capable as they age.

Sign In or Register to comment.