Auto Re-Record?

edited July 2013 in Support and Feedback

Sorry if I've missed this, but is there a macro option (or existing feature request) to automatically re-record the selected loop until punch out? As opposed to auto-overdub...

"Toggle Record, then re-Record until Punch Out"?

I often wanna clean up timing or velocity errors which occur in the first go-round, but dont wanna re-record the entire loop (and I definitely dont want to overdub until the anomaly is fixed). I just wanna punch in/out over the affected duration. Since this is usually an issue with sloppy commencement of the first take, having the re-record set to happen automatically allows easy patching of bad take beginnings.

I suppose I could use "Toggle record, mute, then record next track", but that means re-doing the entire loop via an additional track, which seems a wasteful way to use up tracks when all I'm wanting to do is punch in/out over brief anomalies.



  • You could set delay to 100%, Diggo, and overdub - that'll have the same effect, if I understand you correctly.

  • Thanks Michael, but I dont understand the suggestion. What I'm wanting is to immediately go into re-record without touching Loopy or pressing a midi pedal for the re-record. I want to press the footboard once to commence recording, then I want record to automatically continue (as re-record, not as overdub) until I punch out. Hence a midi binding which does this:

    "Record, then re-record the selected loop until punch out"

    I want to do this at gigs.

    So record stays active until punch out, but instead of overdubbing (which adds a new layer to the existing loop layer which contains the glitch), the dodgy loop layer is progressively erased/replaced by the re-record until punch out.

    This would enable me to get the loop exactly as I want it before moving on to the next aspect of the performance.

    Does that make sense?
    Not sure how that relates to the delay function....maybe you could explain?


  • Michael is talking about the "Decay" feature in loopy, which becomes active when a loop is in overdub. 100% decay will do exactly as you want.

  • aah, yes! OK, I'm on it....thanks!

  • A few probs with the Decay setting.
    Unless I'm mistaken, the decay function doesnt progressively mute the underlying loop simultaneously as the overdub replaces the underlying audio (when following the suggestions above). Instead, the underlying loop is audible - the monitoring crossfades to the overdub after a constant "latency" where the original track and the overdub are audibly mixed (ie both 100% audible for a constant, unchanging time period throughout playback/recording) which makes it really hard to do the overdub because the original loop containing the mistake is audibly mixed with the "incoming" replacement audio.

    The binding I'm using is "Toggle record, then overdub." I've preset the selected loop to 100% decay.

    It's the only binding I could see which might work. There is no "Toggle record, then re-record" macro as far as I know.

    Nor is there a binding which uses mute to achieve the goal, such as:

    "Toggle record, mute, re-record"


    "Toggle record, mute, then overdub" (with decay = 100%)

    The above would be good if below was the result:

    "Toggle record, mute, then overdub, then un-mute upon punch out" (in other words, revert to original take immediately upon punch-out)

    In other words, "Toggle record, then overdub" (with decay = 100%) would be fine except for these factors:

    1. The underlying loop should be pre-emptively muted (via crossfade?) as the overdub proceeds (bearing in mind we are changing the original intent of "overdub") so there is no audible overlap causing old and new to be mixed together in the monitor feed.

    2. If possible, the original audio should only be replaced for the loop duration from start of overdub until punch-out, whereupon the remaining original audio should be immediately crossfaded back up to original level.

    3. I've noticed that Loopy HD frequently barfs on incoming MIDI Clock sync when replaying loops using 100% decay alongside loops without 100% decay, but I might be wrong about the underlying cause or circumstances. I've posted the same info regarding sync problems in another thread. Maybe it's just that Loopy still has some bugs to iron out when synching multiple loops to external MIDI Clock....

Sign In or Register to comment.