[BUG] Track gets stuck in overdub mode

edited July 2013 in Support and Feedback

I have mapped MIDI controls for toggle mute, toggle record, 'toggle record, then overdub' and select next and previous track. I have 'overdub after record' off and all the synchro options off except 'synchronize tracks'. I have 'simultaneous recording' off.

I reset the session and record a loop. Fine.

Then I go the next track and hit 'toggle record' and it starts to record. Fine.

Staying on that same track, I hit 'toggle record, then overdub'. The track goes into overdub mode. Fine.

However, quite often, when I then hit any of toggle mute, record or 'record then overbud', the track stays in overdub mode. This doesn't always happen, but it happens more than half the time. If it does work correctly then usually if I keep going to the next track and doing the same record a bit, then overdub a bit it eventually fails before I've gone through all 12 tracks!

When it's in this stuck overdubbing state, I can go to another track and start recording and the overdubbing track will keep overdubbing and the new track will start recording. When it's not in the stuck state, if I start recording on another track, the currently recording (or currently overdubbing) track goes into play mode as I'd expect with 'simultaneous recording' off.

I then tried turning the 'simultaneous recording' setting on and repeating the same test. This seemed similarly unreliable, with tracks getting stuck in overdub with no amount of toggling able to bring them out of overdub :(

FYI, once a track is stuck overdubbing, even tapping it via the UI won't bring it out of overdub.

Any ideas?


  • edited July 2013

    I should have added iPad 3, V1.4.4 on iOS 6.1.2. Also happen on iOS 7 beta 3 on iPhone 4S V1.4.4.

    Also, FYI, iOS 7 seems to support USB audio devices using the Camera Connector kit on an iPhone. Very exciting as I use the little behringer uca 222. However, loopy is not happy on the iphone when using the USB audio interface, but other audio apps do seem happy.

  • Thanks for the report, Ed - I'm gonna take a look at this when I get some time.

Sign In or Register to comment.