Resolved: More details on network midi control...please!!!

edited January 2012 in Equipment
Hello!

I've been exploring Loopy's possibilities for the past two days, to see what I could do with it on stage...

I'm an accoustic guitar player and I'd like to use Sonoma Wirework's guitar jack to plug my instrument, but it seems that if I do that, I won't be able to connect a midi interface to my iphone4... So no foot controller... EXCEPT if I link the app to a midi controller over wifi if I understood the help menu right.

Would it be possible to have an example of how to achieve that? I have a macbook pro, so creating a private wifi network is easy. But then, how does it work? Do I just plug my foot controller to the mac? Or will it need some sort of third party programme to be launched on the mac?

Thanks in advance for anything on that!

Cheers,

Gwenn

Comments

  • Hi Gwenn,

    I speak from a place of no experience whatsoever, but my *guess* would be that you can set up the routing via the Audio MIDI Setup app. So, plug your foot controller into the Mac, open up Audio MIDI Setup on the mac, then double-click the "Network" item in the MIDI Studio window, create a network session if there already isn't one (the "+" in the top-right list), and finally, set up the live routings in the bottom left, selecting the foot controller in the top selection box, which should basically 'rebroadcast' the messages to the network session. Then, connect that network session in Loopy!

    Total guess though - maybe someone else can confirm or deny =)
  • Thanks! I will try what you suggest this evening and give you some feedback on how it worked... I feel like exploring uncharted territory with this app!
  • Hi again!

    I tried to control loopy with my midi keyboard over wifi, so I followed your advice. The network seems to work because:
    - I detect the network I created on "Network host"
    - In control inputs, when I play a key on my keyboard, I can see it appear on the iphone, and I seem to be able to assign an action to each key

    The problem now is that when I go back to the main screen, nothing happens when I play the keys I've selected...

    Any advice?

    Cheers,


    Gwenn
  • Hey Gwenn,

    Glad to hear it's working so far! You need to enable the network session input under the MIDI setup screen - tap it so that a tick appears.
  • Hi again and thanks,

    The "enable network" is already on... is the tick supposed to look like a beat of the "visual metronome" ? In yes, I have no click...

    Don't know what's going wrong...

    Gwenn
  • edited January 2012
    You need to tap "Network Session 1" under "Control Inputs", and tap whatever's appeared under "Network Hosts", so that they are ticked. Like this: http://cl.ly/1t201r112P283a2X3D3D

    For more info, read the Help section on MIDI - it explains how it all fits together.
  • edited January 2012
    Michael,

    After having looked at your screenshot, this is exactly how it looks like on my phone...

    (sorry I didn't understand what you meant by a tick, but now I do, and I've got it just like on your screenshot...).. and I've read the help section on MIDI, so I really don't understand what's not functionning....

    Cheers

    Gwenn
  • Have you definitely assigned the right actions to MIDI events, Gwenn? What're you assigning?
  • Hi Michael,

    Thanks for your patience. To make things clearer, here are the snapshots of my setup:
    http://www.flickr.com/photos/[email protected]/sets/72157628879581785/

    Cheers

    Gwenn
  • I don't see a tick under the "Control Inputs" heading.
  • edited January 2012
    Hey Michael,

    Thanks a lot! It works now! I was mistaking the tick for the disclosure button... It's now working perfectly!

    Thanks for your patience helping me through.. At least it will serve as a good lesson learnt for others planning to use a midi controller over wifi!


    Cheers,

    Gwenn
Sign In or Register to comment.