Yamaha MFC10 problem - both button 1 and button 0 send PC0

edited March 2013 in General

A big breakthrough for me tonight. I bit the bullet and plugged it all in and 'had at it'! The whole MIDI / 'bindings' thing isn't so scary once you have it all connected and sitting in front of you. Remember to put a tick next to your interface though!

I got to start and end recordings, select tracks, blah, blah... I guess it's just a matter of rolling up the sleeves and getting stuck in.

One thing that's REALLY annoying me is that button 1 shows in the bindings as PC 0, button 2 = PC 1 etc... [edited..] I'm sure that makes sense to someone out there in midiland, but not me.

The manual is no help - even though its (allegedly) written in English.

So... is this labelling system set in stone or can I change it to a more logical system, either within Loopy or in the controller itself?

Or do I just have to man up and put up with it?

Cheers to everyone for all the help so far.

Comments

  • Another 'problem'... When I went to 'bind' button '0' to an action, it said "PC0 already in use".

    I now find that button '1' & button '0' are both PC0? There must be a way to assign a specific Program Change to a specific button, surely?

    @oscarecroe, where are you? Please help.

  • edited March 2013

    Glad you had a good session :)

    The 1 = 0 thing is annoying, but ultimately doesn't matter with Loopy as long as you remember which function each footswitch has been assigned to.

    In your first post you say that button 0 = pc9, and then in the second that its sending PC0. Is the action you want to assign to 0 the same that is already assigned to button 1? If so, loopy will tell you that that is already in use. If you would prefer the binding to take place on button 0 rather than button 1, delete button 1's function and start again binding to button 0.

    I could be barking up the wrong tree, but I recall a similar thing happening when I started bindings with my very old Boss FC50.

    The MFC10 looks pretty cool!

  • edited March 2013

    Oops, a clarification. In my first post I 'assumed' that button '0' would be PC9.

    When it came to making the bindings (not sure of the correct terminology) I found that button '0' didn't do anything except make button '1' active. (ie, press button 0 and button 1's LED turns on.) It's as if buttons '0' and '1' are in parallel. When I tried to bind an action to button '0', Loopy thought I was using button '1' again.

    I've reset the controller to factory settings a number of times but I've still effectively only got 9 functioning buttons.

    I guess I can live with the 1 = 0 thing as its only an issue when making the bindings. I just have to have a paper and pen handy. (1 = 0? Who's dumb idea was THAT?)

    ...and while I'm in the nooby-dumfuk-novice stage, I might even break out the Dymo labeller for the controller.

    And yes, it is a pretty cool bit of kit - I really like its form. Its bigger than it looks in the photos - almost as big as the Behringer.

    If I can just sort out this 1+ 0 button doubling-up, I'll be a doubly happy camper.

  • Ok...wrong tree! I guess 0 has a different function...I had a very quick look at the manual but nothing stuck out to explain it. Any MFC 10 users here?

    Dymo is a good idea, my FC50 gets the masking tape and marker treatment.

    Good luck!

  • Thanks anyway.

    I can't find any technical support links on the net either.

  • Is 'bumping' allowed?

  • I'd like to know, too...and I don't own one of these gadgets!

  • Brother Muzza, ( I assume gender by generic avatar,you go to the same barber as me?)

    It's been a while since I've used the MFC10. Other smaller lighter more complicated options on the floor and some in the drawer! I couldn't pass on the price when MFC10 came to me several years ago.

    Are you in normal or mix mode on MFC10? "Program change memory" or "function memory"?

    I don't have Loopy until everything proves to work the way I need it to, so I can't help you if the error occurs in Loopy's binding behavior.( I've been absent here so maybe it's functionality has changed and I'll have reason to buy an iOS device)

    Often with midi controllers and devices:1=0, unless the receiving device allows you to change the starting point.The MFC10 This is an age old issue, most new developers now make it possible to have your #'s match. (see MFC manual "note" on top pg. 10)

    On the pedal board the "0" would indicate "10" ; "20" ; "30" ; etc. depending on where the "x10" has been set.What # is on the MFC display when you punch "0" ?

    Have you looked to see if your "1" and "0" buttons are sending the same data?
    I don't want to get into the ins and outs here,but @ pg.10 of manual there is a pretty thorough explanation of how to see what data is programmed for each button. Just follow the edit steps and see if buttons "1" and "0" are sending the same data.

    As for labeling, if you use console tape it won't muck up the finish or leave residue like masking tape or Dymo.

    Now, the most important question for me:
    Are you experiencing any latency between when you punch a button and Loopy reacting? If not, maybe I'll pull it out and mess with it again. I like the large buttons even if it eats real estate on the floor.

    I'll check back here when I have time. Hang in there and have some fun with it! Sorry this was a bit hit and run.Got to go.

    Respect, Otis

  • Brother Otis! YOU'RE BACK!

    Thanks for your input.

    Well, to answer YOUR question first, no, I don't notice any latency at all, but my timing is so atrocious at the moment (seriously) that there could be a significant delay and I wouldn't know. But, apart from the above 'problem', I'm having a lot of fun 'getting better'!

    Now... yes, both button 1 and 0 send the same signal - PC0.

    If I press button 1, button 1's LED turns on and '001' shows in the display. If I press button 0, that ALSO makes button 1's LED turn on and display still shows '001'.

    I checked it with 'MIDI Monitor' and that confirmed both buttons are sending the same signal (or whatever it is they're supposed to send)

    Later...

    OK, I'm over in the studio now. (Most people would call it a garage) the board is switched to 'Normal' and the Function button isn't activated. I'm VERY new to MIDI and I don't even know what the function button does, or what's the difference between 'PC' and 'CC'. All I know is that the pedal currently works as I want it to with the Function light off, so that's how I'm leaving it for now. (No, that's not a poorly disguised request for you to teach me MIDI - baby steps... all in good time)

    So, a re-cap - press button 1, '001' shows in the display, press button 0, '001' shows in the display.

    Next step, I tried selecting the 10 button, then the 0 button and '010' showed in the display. Pressed the 1 button and '011' showed in the display. That tells me the controller works properly, it's just misbehaving on the first level, for want of a better description...

    The note you pointed me to on page 10 makes more sense now. It looks like there IS only 9 available choices at the first level, as its not possible to select '000'. Looks like the only way to get all 10 buttons functioning is to go up to the next level and use 10 - 19 (PC9 - PC18)

    It would be great if you could edit the board so you could assign PCs to buttons - so we could make '1' = '001' and '0' = '000'. But that would make MIDI available to everybody.... (Hmmm...)

    Cheers for your help. I'll keep you informed.

  • I never use the program change..I stay in function mode.

Sign In or Register to comment.