Oops you've discovered a problem with the audio system. (Apogee Jam & Alesis Dock)

edited February 2013 in Support and Feedback

Michael, thanks for a super fantastic app.

I've run into an issue which I've now seen with two separate devices: the Apogee Jam and the Alesis i/o dock.

The issue is the if the Apogee Jam is plugged in when the iPad (1 in my case) is turned on, then when Loopy is launched, it throws the "Oops you've discovered a problem" error message. If the Apogee Jam is plugged in after the iPad is started, the everything works fine (except for the latency issue on loaded sessions vs new sessions - currently being discussed in another thread).

On the Alesis dock, Loopy works fine unless the the "guitar" toggle is turned on on the rear panel. Then Loopy throws the same error. That "guitar" switch on the dock is designed to provide a signal through to the main out - making the dock function much like the Apogee Jam.

So i think that the two cases are related. I found a workaround for the Jam (plug in after startup), but the Loopy / Alesis dock seemed more volatile. I couldn't get it to work reliably at all (kept throwing the error when the "guitar" switch was on). I ended up returning the dock and was going to try the new Behringer dock, but just found out they're not available till June.

Any thoughts on what's causing this behavior?

I just had one which is to try turning off headphone monitoring. Maybe that is somehow conflicting with the iPad system audio.

Comments

  • edited February 2013

    Yes, confirmed. If headphone monitoring is turned off, then Loopy starts up fine (no error message) with the Apogee Jam plugged in from device startup.

    When headphone monitoring is then turned on, it references the iPad's mic instead of the Apogee Jam which is plugged into the iPads charging connector. So in effect, the error message is avoided, but the Jam cannot be used.

    And so I guess the same workaround mentioned above would work with the Alesis dock:
    1. Turn on iPad
    2. Turn dock's guitar switch on
    3. Slide iPad into dock

    Is it possible to fix this behavior?

  • Cheers @Ironlion!

    Hmm, is anyone else able to replicate this?

    I've not been able to yet: I've got an iPad 3 with an Apogee Jam; I plug in the Jam, then start Loopy (with Headphone Monitoring on and headphones plugged in). No error, and everything seems to work fine.

    Have you tried rebooting your device, in case that helps? Are you using the latest iOS version?

  • Hi Michael, I am using the latest software for my iPad 1 (5.1.1).

    The issue is caused when the apogee jam is plugged in before starting the iPad. So, if I reboot the device with the jam plugged in, then it will show the error.

    On your iPad 3, what happens if you make sure headphone monitoring is on in Loopy, turn off the iPad, plug in the jam, turn on the iPad, then start loopy?

  • Ah, forgive me, I totally missed your 'device startup' comment.

    Okay, so I followed your directions (actually followed them, this time!), and - nope, still no error. Turned off iPad, plugged in Jam, turned on iPad, started Loopy (with Headphone Monitoring on) - seems to work fine. I'm using iOS 6.1, so perhaps this is an iOS problem?

  • Well, I returned the apogee jam and went back to the alesis dock. And now I can't replicate the issue. Maybe it's all about making sure loopy is the first app started after the iPad is booted.

    I'll post again if it starts happening but hopefully it's a non issue now.

    Thanks :)

  • Weird stuff! Okay, well do let me know =)

  • Happened again today. I sent you the error report by email.

  • Cheers, @Ironlion - weird stuff, that error isn't even documented by Apple.

Sign In or Register to comment.