Logidy umi3 Setup

edited January 2013 in Equipment

Anyone using this pedal for control? Loopy recognizes my pedal in the midi control window. I selected it there, but it does not create a binding when I depress any switch. Switches are generating c5, d5 and e5, respectively (per midi monitor). I don't believe the note is important, but any help here would be greatly appreciated. Thx very much.

Comments

  • edited January 2013

    Have a look at this thread in case it helps... Maybe, maybe not, but @ganthoffer went to extraordinary lengths to help @abrokenrecord.. It might get you thinking of some 'debugging' steps to take:

    http://forum.loopyapp.com/discussion/comment/2608#Comment_2608

    Also - tell the community here as much as you can - we might think of something to help. I know I've used notes from C2 up to E2 and they worked well. I actually leave bindings in there for program changes as well, because I can load a diff template for my pedal and have it control Loopy a different way in seconds. Tell us all more... See if we can help,

    Gary

  • Thx, Gary. I just took another look at this thread and may try to assign a program change to each of the three switches. Right now, generating a note, Loopy just keeps "waiting for event." That makes me a little nervous, because @ganthoffer indicated that a note should suffice. I'll try making changes tonight and circle back.

  • I suppose that's why I highlighted that post... You might need to debug it with other gadgets and apps to drill down to the 'real' problem. Simple things like the midi indicator light flashing on your interface when you press the pedal. MIDI monitor app, etc.

  • Well, this I know:

    1) Loopy sees the UMI3
    2) Midi monitor reads the notes when the respective switches are depressed
    3) Lights on the pedal flash when switches are depressed

    Beyond that, not much else going on, so I'll try plugging into the computer and checking/changing pedal settings in the editor.

  • I would expect that if you see it in the MIDI Monitor app, that it should show up when adding a binding in Loopy.

    Do you see both the Note On ( Note and a velocity > 0) and a Note Off ( Note Off or Note and a velocity of 0)? Shouldn't matter really, just curious, as I am not familiar with the umi3 (and about a million other MIDI controllers )

    There is an issue with only trying to bind the Note Off, but since you haven't been able to bind anything, it's not relevant yet.

    http://forum.loopyapp.com/discussion/comment/2535#Comment_2535

    From your description, it sounds like you are in the write place to add bindings, but just to be sure..

    For the bindings in Loopy, you are going to:

    • Settings
    • MIDI
    • Control inputs " your device name umi3" and pressing the ">" symbol
    • Add binding

    Not under:

    • Settings
    • General
    • Key bindings ( only for Bluetooth devices - keyboard, Airturn, ...)
    • Add binding

    Definitely give us more details; type of iDevice (iPhoneXX, iPad X), software version, Loopy version, ... The umi3 is MIDI class compliant USB device (?) connected to a powered USB hub (?) and into the iDevice via CCK (?)?

    Do you have any other MIDI devices? Do you have any other MIDI Apps?

  • Wow, @Ganthofer. I think you scored again. I was in the wrong place - general/key bindings. I'm on the "new" iPad (retina/3/?). I have confirmed that the UMI3 is class compliant and gets enough juice from the bus, through the Apple cck (already tested a couple of these to eliminate it from the list of causes). So far I have not plugged in any other midi devices while trying to get set up and I shut down all other apps (again, just trying to eliminate potential causes). Anyway, I think you have it diagnosed and I'll confirm asap. Thx!!!

  • Confirmed, it works! Thx very much, guys.

  • Also - about the note on/note off bindings: how I make sure I bind to 'note on', is by pressing 'save binding' (or similar), While still holding the pedal down. This way the pedal hasn't sent a note off when you save the bindings... It saves note on as the binding, and the pedal fires the note off message after the binding is already set (when I let the pedal back up) - only an issue for notes, not for program changes, of course. For me, it means I can do a percussive down beat to punch in and out - so much harder to control when you let the pedal up!!

    @Moonwolf, Hope your problem is fixed. This is just an extra work-around I thought I'd share.

  • @moonwolf So does the UMI3 work well with Loopy? Any latency issues? Do you recommend it? I like the price. Are you able to use the third pedal to toggle between notes?

  • @Astropunk, sorry for the delay. It has been working well. I am using note commands and have the pedals set up for (from left to right) record, clear and stop & reset. Loopy is so feature laden, though, I'm already looking for a new foot controller with more buttons.

  • Hi guys,

    I'm new here. I don't know if anybody has tried this but I just did and was really surprised it worked. I took a iPad2 and used a camera kit usb adapter on it so I could plug in a old USB powered hub into that. Then into the hub i plugged in my ijam and my UMI3. I used audio bus so I could run my guitar signal through AmpKit then into Loopy. I was able to set my midi assignments rather easily.

Sign In or Register to comment.