Cannot turn off internal microphone

edited November 2012 in General

Hi,

Have been messing around with this app a few days now. It's really cool.

But today the fun ended ;)

I cannot prevent recording from the internal microphone. No matter if I use my interface (iRig-rippoff: Flanger) or not.
I have turned off both Live playthrough and Record live audio. I have rebooted and restarted the app.

Are there more settings that I might have changed?

«1

Comments

  • Ahh. yes.... Sorry about that - that's a bug in the latest version, if I understand you right - I've fixed it in the next one, which should be out in the next week or so. Sorry about that =)

  • Ok nice! :)

    Is there a way to get around the bug in the meantime, since the app worked fine a few days ago?

  • Hmmm - your best bet is probably to delete then reinstall, I'd say. If you've got some sessions/recordings you want to keep, transfer them out via iTunes/iExplorer/etc, zip them up, and put the zip file back in the Documents folder after you've reinstalled.

  • Ok, thanks.
    I will try that. :)

  • This still doesn't seem to have been fixed in the current update. Any word on when it will be?

  • Oh! I'm sorry, I must have misunderstood the actual problem - I just read through your original description again. Are you saying that even when you plug an audio input device into your iDevice, the audio's still coming in the device's microphone? That sounds like a hardware problem to me, not a software one. Does it work in any other apps?

  • No. I can't turn the internal mic off when I am using the device on it's own without anything plugged in. Even from the settings within Loopy.

    So if I import a few loops and then connect to Audiobus I can hear audio from the mic as well. This happens even though I have turned off the mic in settings.

    This only seems to happen with Loopy so I'd say it is a software issue.

    I am running an iPad 2 with iOS 6.

    Cheers
    Sevrink

  • Ah, right okay - do you have any other apps running in the background, which might be using the mic?

  • No just Loopy on it's own.

  • Okay - do you still hear the mic even when Loopy's connected in the Output slot in Audiobus?

  • Unfortunately yes I do.

  • I'm afraid at this point I'm utterly baffled, as this should be impossible; just in case I misunderstood your original message, let me just verify:

    1. You are hearing - live, as in, live audio monitoring - the mic input coming out of the headphones when using Loopy, despite having "Headphone monitoring" turned off, and
    2. You are still hearing this live audio from the microphone even when Loopy is connected as an Audiobus output, with a non-microphone source, and
    3. You have no other apps running that might do live audio input monitoring.
  • Also - is your device jailbroken?

  • Yes. That is exactly it! Basically, the internal mic is continuously on no matter what i do.

    No my device is not Jailbroken.

    I will try uninstall and reinstall it a few times when I get home. I will let you know my results.

  • Ok...so after uninstalling and re-installing the internal mic is now switched off when i use Loopy as an output instrument in audiobus.

    This seems to be the only way the internal mic is switching off from within the app.

  • Hmm, okay - I'm putting this in my "weird shit that happened" box, and will keep an eye out for further reports. If it happens again, try to lemme know any details of the events leading up to it - I'd love to be able to reproduce this myself.

  • No problem. Thanks for your time Michael.

  • Oké, i have the problem that i always hear the mic input with a recorded app like sunrize or funkbox......with headphone plugged in.

  • edited December 2012

    Michael, if you turn off 'live input recording', then it shouldn't record from the microphone, should it? Apologies if I've misunderstood. I've got an io4 so the internal mic isn't normally an issue for me. However, I've just had a play tonight stand alone, and the internal mic is leaking into anything I record. I can also see the mic input levels flashing if I tap the device, say - should this not show a level if 'live input recording' is disabled?

    A work around (and also some interesting info is gained if) I put Loopy on the output of audio bus. Interesting, though, that if I have nothing in the chain of Audiobus - it feeds mic through to Loopy. But... If I add something like nlog synth as the input, Audiobus drops the mic, and will only pipe this through after that if I specifically add the internal mic as an extra input.

    I'm not 100% sure that it behaved like this before Audiobus, but who knows?

    Does this give you any clues for the internal mic? If nothing else it's a work around for others with this problem... If they have Audiobus, of course :)

  • Hey Gary - it shouldn't record from the mic for session recordings, no. But, it'll still record from the audio input to tracks (and show the input level in the panel). Note though, that 'live input' refers to whatever input device is being used, whether it's the mic, line input or Audiobus.

    You should never see input from more than one of those sources at once...

  • Loopy HD was working great, but all of a sudden the internal mic came on in the program and is now unusable. I tried deleting and re installing, turning off live input and headphones. I am running iOS 6.1, on an ipad mini. Do you know if this problem returned with the iOS update?

  • Would you mind using the "Email Support" function from within Help, @GrokklyRob, so I can see some diagnostics? I've heard this happen to someone else, who was able to remedy things by reinstalling if memory serves me right, but at this point I have no idea why it might be happening.

    Just to clarify, too - you're saying that you can always hear the internal mic through the audio output: As in, monitoring is always on, regardless of the actual "Headphone Monitoring" setting?

  • Interestingly, I experimented with using a simple cable wired to connect a mono audio input (bus) from my mixer into the mic input of the iPad TRRS audio jack, and the TRSS stereo output to a couple of mixer input channels. That didn't work on my iPad; Loopy (or any audio app) always picked up audio through the internal microphone and not the mixer input, even with a healthy signal applied. I don't think there was enough impedance at the input to disable the internal mic.

    So ... with the same connections and cabling ... I soldered a 1k Ohm resistor across the mic hot and ground inputs, and a second 1k Ohm resistor in line with the hot input. Now, all is good. The internal mic disconnects, and I get my audio input from the mixer as expected.

  • Hi Michael, I think the diagnostics were submitted through the application. But I think I made a mistake. When "Headphone Monitoring" is off, the sound from the internal mic stops coming through, but the loops and samples will play through the headphones. I suppose it was that I kept seeing, to the left of the "play" button in the orange section on the right, the input from the ipad mic visually.

    But all seems fine. For instance when I input from the pasteboard a track from Voice Synth, then use MultiTrack DAW to record from Loopy (through AudioBus), it only records the sound from the loop, and doesn't pick up the internal microphone.

    I hope this helps clarify things, as I think it is not an application problem but rather an operator's error.

  • Okay, Rob - well, good to hear =)

    (Also, *gapes in awe at soundog's electronics wizardry*)

  • And you think all of us are not gaping in awe at Loopy's wizardry? Honestly, I try a lot of audio and music apps (far too many!) and yours is one of the best I have encountered. To top it off, you remain connected with your users, and listen to their input. Loud applause.

  • Similar problem here. When i want to use say animoog to loopy via audiobus The internal mic is silenced, but when I try to use an external mic to loopy via audiobus the internal mic does not silence. Can there be a fix that disables the internal mic with any audiobus input to loopy please ?

  • Cheers for the detailed report @Wasabee - I'm gonna check this out.

  • @Wasabee, I think this might be the same problem @soundog investigated earlier; it sounds like your external mic doesn't have enough impedance to cause your device to mute the internal mic. Have you tried with other hardware, or other software?

Sign In or Register to comment.