There was a problem with the audio system (OSStatus error 1836282486.).

Hello

I try to understand a problem because loopy pro seems to be a yet great and furthermore promising software, so I intend to use it on my iPhone (a 12 mini, with iOS up to date 15.5 , Loopy Pro up to date too)

The problem is , text and image to follow :

There was a problem with the audio system
The operation couldn't be completed.
(OSStatus error 1836282486.).

To systematically reproduce this, I do :
1. have the sound card plugged in , check that the sound output is set to it ( on the iPhone's control center 'Audio Out' is checked )
2. start your favorite synth ( synthwave, model D, ... ) check that you hear the sound through the card.
3. start Loop Pro , got the error :/

The sound card is a Motu 1248, that otherwise works fine, until loopy pro is started.
I checked on other devices : iPads and iPhones and have the same problem, so I guess it comes from a specific thing with the Motu 1248 + Loopy Pro.

I sent a mail to Michael and uploaded a diagnosis file.
I know bugs are hard to reproduce and identify clearly.
The interesting questions for all of us me thinks, to ensure that Loopy Pro is stable & reliable , are :

  • Has someone encountered this error message / problem ? with which sound card ?
  • And is willing to help solving the issue by providing more use case ( the context and how it has been reproduced ) ?

Cheers and happy musiking to all.
Frantz.

Comments

  • Just saw that there is a "support & feedback" category on the forum where my above post shoud be, sorry.

  • edited June 4

    No worries about the category, is a fairly quiet forum anyway – I recommend also posting this over on my other app’s forum (Which happens to also have a Loopy Pro category): https://forum.audiob.us

    For the record, though, your setup is the first I’ve heard of with this persistent issue, in 10 years or so on the App Store, so it does seem quite unusual.

    I’ll get back to you soon with the results of my investigation (I’m taking a much-needed a few days off, so I’m a bit slow with that!). I suspect the answer will be that this is a crash in the iOS audio service (which is indicated anyway by that error message), and we will need to submit a bug report to Apple and hope they fix it in a future iOS build.

  • Hello

    Yep, no worry, no hurry :)

    Thanks for your answer.

    For now the workaround is : quit loopy, disconnect, reconnect, wait for audio out, launch loopy.

    If it's a problem with the Motu 1248 ( otherwise 'class compliant' ) , then I'll have to break my piggy bank for a new and 'live' oriented sound car,

    Maybe there is a list of "known to work well" sound cards or even complete setups for Loopy Pro somewhere ?
    Michael, have you seen that Yamaha updated its AG06 mkII , seems nice to me , would you recommend ?

    Cheers,
    Frantz.

  • I'm afraid there's no list - honestly, until now there's been no need for one, this is the first time I've seen a recurring issue like this!

    So the diagnostics you sent were interesting but didn't really shed any light on the issue – there's definitely a host of odd errors and stuff showing up from iOS' media server, as well as lots of service restarts. No actual crashes of the media server per se, though, and it's really hard to tell what's going on.

    I've contacted Motu to see if they'll lend me a unit for further diagnostics; we'll see what happens there, but it won't be soon, most likely.

    I'm also interested to know – just for the purposes of seeing if there might be workarounds available – what other apps you've tried this with. If you swap out Loopy Pro for, say, Audiobus, AUM, Loopy HD, really any app that does play + recording, what do you see?

  • Let's use the young brother Loopy HD.

    It works like a charm, here is what I did this morning :

    • switch on the motu & the speakers & amp
    • unlock the phone
    • plug the motu on the phone
    • wait & check in the control center that audio is set to Audio Out
    • launch loopy hd
    • record 3 vocal donuts
    • quit loopy Hd
    • relaunched loopy Hd
    • did another recording
    • quit loopyHD
    • checked In control center that audio is still set to Audio Out
    • launch Loopy Pro
    • got the same error with the same number
    • can't hear nor play any sound

    Then I continue with the "workaround" that makes it work :
    - quit Loopy Pro
    - in control center the audio out is now set to iPhone internal
    - disconnect the motu - reconnect the motu - wait for Audio Out to be set
    - launch Loopy Pro
    - no more error , that makes it work

    Some more info for Motu : the firmware is the last update available, version " 1.4.0+90954 03/31/22 12:38:56 ".
    I also updated the iPhone 12 mini, the iPad 9 to iOS 15.5.
    My next idea to to hard reset an iOS device and try, but I'm not sure this will change something because the problem occurs on 3 different devices already (iPhone 8 , iPad 9 , iPhone 12 mini ).

    In the test case above, the problem occurs between :

    • Quit loopy HD ( or Garage Band )
    • Start Loopy Pro
      And it shows during the acquisition of the "OSS" OperatingSoundSystem.

    The Motu still works fine with the MacBookPro & Bitwig Studio, my original setup.

    Don't hesitate to ask me any test, any help, as a software developer I'm also curious to understand technically how this works, and I'd be glad to help. That issue surprises me too.

    Cheers,
    Frantz.

  • Huh! Fascinating! That’s great to know it works with HD; I can compare the order of operations. This is definitely an iOS/driver bug but it looks like I should be able to find a workaround. I’ll get back to you - I think I’ll need to get you to test some code, if that’s okay. Do you have Xcode available, by any chance?

  • Yes, that would be a pleasure.
    I do two main things on the MacBookPro : Bitwig and Xcode.
    If Apple was completely moving Xcode to the iPad , then I could sell the MacBook and do LoopyPro & Xcode on an iPad Air 5 !
    Testing some code will be the occasion to learn about this part of the API that I haven't used yet.
    Fun ;)

  • edited June 6

    Great, I appreciate that! Before we go down that rabbit hole, would you mind trying Audiobus as well if you have it? (let me know if you don’t)

    AB uses the same audio engine as LP (TAAE2), so that will be most instructive.

    If worst comes to worst, Motu got back to me and I’ve got the contact details of the local Motu distributor, who will probably be able to lend me a unit for diagnosis.

  • Hello Michael,

    I send you my coords by e-mail in case you want to 'TestFlight' me.
    I do not have AudioBus.

    I thought that the issue could depend on what the Motu gives back to the software when it asks for the card's inputs.
    So I reduced (reset) my configuration to something easy :

    • in Motu console , under the "Device" tab , I click on "Launch Quick Setup"
    • then I chose "Interface + Mixer" in the list of choices
      And that's it.

    During my trials, I noticed that Bitwig (on MacOS) takes the "toComputer input" from the Motu's mix matrix, whereas GarageBand or LoopyHD always take the "physical inputs".
    So maybe there is a difference in the API between iOS and MacOS, something that does not please iOS's in the Motu's answer to 'give me your inputs'.
    Anyway this is just an empirical hypothesis, things are better solved with real logs and debugs ;)

    Frantz.

  • FYI: @ArfNtz and I had a bunch of back and forth (I even tried to get an Motu to test with, with no luck due to chip shortages), and it turned out the Motu has a hissy-fit with certain sample rates. He changed the sample rate setting in Loopy Pro to "auto" and that seems to have fixed it all.

Sign In or Register to comment.