Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has only a small number of active users.

Adding midi guitar as midi source is blocking audio input

edited February 11 in Techniques

@Michael When I add midi guitar AU as a midi source, then the normal guitar sound stops coming through my audio input - instead all sound comes from midi guitar. Tried unplugging my audio interface and using my iPhone's mic input, this is also blocked as soon as I add midi guitar 2.

Once randomly audio came though both channels at once but once i added a midi destination my audio input dropped out again. Not managed to replicate this.

Muting/turning off midi guitar doesn't make any difference.

If there's not currently a way of having sound come through both at once, can you add an action to disable a midi input so that i can turn midi guitar off and get my normal guitar audio input back? (And an enable to switch back, of course). Either that or make the midi mute allow the audio to come though the main audio.

Then I can switch between them easily as I please.

Afaik i can't stop this behaviour from within midi guitar. I can change the audio channels in the main midi guitar app but that option doesn't seem to work in its AU.

If you think that restricting the midi guitar AU to 1 input channel should let loopy access the other one then let me know and I'll look into doing that with midi guitar.

Thanks!

Comments

  • Ok my bad - midi guitar's mix control that adjusts the balance between the midi output and the guitar output solves everything!

    Unfortunately I can't adjust this variable as an effect parameter - when midi guitar as used as an audio effect it doesn't expose any effect parameters, and midi channel no AUs don't seem to have any effect parameters either.

    @Michael presumably midi guitar au just doesn't expose parameters and I'd need to ask their support to support this rather than you?

  • Sounds like it, yeah!

Sign In or Register to comment.