CWE Xkey Air 25 doesn't work - Loopy Pro

edited January 15 in Equipment

It works fine with Loopy HD and all my other BLE compatible apps but my Xkey Air disconnects itself within a minute as soon Pro is loaded. In that short time I can bind a NOTE but it won't trigger the Action. I'm on a iPad Air 2 with iPadOS 14.8.1. Latest midimittr, Xkey Plus. As long Loopy Pro is not running, the Xkey will not disconnect itself, even when not in use. This really sucks because I used the Xkey to select and arm tracks etc. Hope this will be fixed soon!

UPDATE
If I don't do any MIDI Learn, the Xkey keeps connected in the background, even when Pro is running. From the moment I bind a NOTE, it will trigger the action (Play/Stop) only once and immidiately disconnects the Xkey and I need to quit all apps, disconnect Bluetooth in System settings and turn off/on the Xkey to reconnect it again. Dissapointed!!

Comments

  • edited January 19

    Is all your gear up to date with the latest firmware? This’ll be a hardware bug, most likely (Bluetooth connections are handled by the system, and not Loopy Pro).

    It sounds like perhaps it’s not properly handling return midi feedback, which Loopy sends to controllers. I will be shortly adding a setting to disable/configure feedback, so that may be a viable workaround if there isn’t a firmware update available for your hardware.

  • Hi, I've updated all my WIDI Master firmware etc. and it seems to work for now but again lost connection after a while. I also noticed when in 'MIDI learn mode' the visual confirmation of which MIDI note is binding, it alternates between Virtual MIDI and Xkey BLE Air as a MIDI source each time I press the keyboard. I don'y understand why this is happening but I will investigate this further and update this thread for future references. Love the new Pro app btw! Good work!!

  • edited January 23

    UPDATE: I found the culprit. Besides the CME Xkey Air I also use two WIDI Masters in my workflow. Out of the box they all pair automatically (being the Xkey and second WIDI Master 'peripherals' and the WIDI Master the 'central' in a 'group' and because of this 'internal' connection, they are all no longer accessible in the iPad. It took me quit a while to get my head around this behavior but the solution is you need to disable them as group and connect them one by one in the iOS BT settings and midi mittr. This is rather inconvenient but for now the only solution.

Sign In or Register to comment.