MIDI Clock issues at 155 bpm

Tossing this out there, but I have been using Loopy with Bandhelper for a while. Bandhelper is my Master Beat Clock. It sends the tempo to Loopy, and I use a MIDI file that is running in Bandhelper (in parallel with a backing track) to turn loops on and off. Works great...I have been doing this all live.

Recently I tried to add a new song and noted weird behavior...the loop would stutter intermittently. I have done hours of trouble shooting on this, including discussions with the developer of Bandhelper. I have traced this down to it being an issue EXCLUSIVELY with 155 bpm. I can see the tempo jitter on Loopy when Bandhelper is sending MIDI Clock data at 155 bpm. My solution was simple...I went to 154 bpm with the song and it resolved. I can also make it 134, 153, 157...doesn't matter.

I also could reproduce the tempo jitter by sending the Tempo from Bandhelper without a running mp3 and midi file, so it does not appear to be related to my midi file itself. The loop jitter did not occur, just the visible jitter in the tempo, which I suspect just has to do with less processing that is going on in the iPad with the stripped down conditions.

Anyway, Arlo with Bandhelper was out of ideas, so figured I would toss it your way for thoughts. I can certainly live with it, just avoid 155 BPM.

Comments

  • How weird! I’d definitely like to get to the bottom of it though. Do you have Audiobus? It has a diagnostic system which records the midi clock so I can take a look. If you have it, here’s how: using the latest version of Audiobus, open the system preferences app, then find Audiobus, and turn on Diagnostic Mode. Then open Audiobus, and set it up to receive the clock from Bandhelper and run for half a minute or so. Finally, open Audiobus settings, and tap Get Support.

  • Ok. Just sent it.

Sign In or Register to comment.