Loopy HD: Difference in Behaviour Between USB and iRig Input

I'm using an iPad with Loopy in conjunction with the TC Helicon VoiceLive Touch stand-mounted vocal processor. The VLT has its own inbuilt looper, but I prefer to use Loopy because it's vastly superior.

I have had it connected to the VoiceLive Touch via USB and the iPad Camera Connection Kit; the VLT is recognised as an input, and Loopy works well. However, I found it only recorded the dry versions of my input from the VLT, just the mic sound without harmonies or any effects. This was not what I wanted, so I checked the VLT manual. I found that the USB-out signal can be in one of three settings. I had selected TRACK, which intentionally strips the effects from the mic signal for recording into a DAW, so they can be added later. My mistake, I thought. Instead I selected USB STEREO out, which immediately allowed me to record the full VLT signal with effects and harmonies into Loopy. Sorted, I thought!

However, I found that when I recorded a second or third track in Loopy, the original loop was being re-recorded as well. There was no way to mute one loop and select another, as they all piled up on each other... Bummer!

I tried various settings in Loopy but was unable to fix the problem. I then tried outputting the VLT signal into Loopy using an iRig analog connector via the iPad's headphone jack instead. This time I got what I wanted: full signal from the Voicelive Touch with all harmonies and effects, plus isolated individual loops in Loopy that could be muted or activated as required.

Fine, but that means my whole sound now has to go into the PA via a flimsy 3.5mm headphone lead out of the iRig, and the tone is noticeably thinner as a result. I would far prefer to be able to use the USB connection via the CCK because of the superior sound, but for the life of me can't get Loopy working as it should.

Please can someone help with this? Perhaps I've missed some setting in Loopy that will do the trick.

Comments

  • It seems you send the audio from loopy back to your VLT, and then back to Loopy.
    Do you see what I mean?

  • Yes, I know - but why is that happening? When I use other USB interfaces with Loopy, it doesn't. On the USB Track output of the VLT it doesn't either, but then I get dry tracks with no effects in Loopy. With the Stereo USB output I get the effects, but also this odd behaviour of every new loop recording the previous one. I can't work out how to make it behave as it should.

  • You might want to check in your VLT if somehow you can disable the routing of the USB into the USB out

Sign In or Register to comment.