Solution for Latency when recording loops?

New to loopy but m totally familiar with audio interfaces ,connections ,latency settings etc. I am using a zoom q4 in usb mic mode and connected to my iPhone via apple camera connection kit ie lightning to usb. The q4 mic is much better than iPhone.
So I am getting the q4 audio into loopy and I already set latency in loopy to lowest of 128. When monitoring I still hear a double attack on every note from my guitar as there is a clear time lag when I hit my strings and when it comes through my headphone .
So I just turned off the monitoring feature . I can still hear the guitar sound anyway as it’s an acoustic gtr. Still when I record loops and I play perfectly on time with the metronome, all my loops sound out of time because they are recorded with the latency ! What do I do now? Pls don’t ask me to manually drag around every loop to correct its timing. I don’t want to do this when I have played it perfectly in time.

Comments

  • Hey @nandak - ouch, that sounds like your audio input isn't reporting its latency properly. Most audio hardware gets this right, but some don't, and then Loopy is unable to properly line up the incoming audio with the outgoing audio.

    This would require a manual latency control override to work around the incorrect reporting from the audio hardware. I'll see what I can do about adding something like that to Loopy. Until then, I'm afraid your options are pretty limited: try some different hardware.

  • Strangely I don’t seem to be getting this latency problem when using the same zoom q4 in GarageBand. It may be a very very small latency in GarageBand which is not noticeable. Anything can be fixed in loopy ?

  • I would LOVE to be able to manually change delay compensation time.

Sign In or Register to comment.