Recent update broke MIDI sync

After a couple of years of good sync to MIDI Clock, the latest update seems hosed (for me at least). Sync keeps lagging. iConnect Audio 4+ DIN provides the sync. Other devices in the system are fine - only the Loopy device loses sync. Latest iOS.

I completely removed Loopy, then tried installing my "golden" version 1.53, but for some reason that version cant access the microphone in latest iOS. Boo! So, reinstalled latest version, doesnt sync. My bandmate's system syncs just fine (to the same sync source)

This is a nightmare I was hoping to never revisit, but I'm back in nightmare mode again, with bandmate suggesting I abandon reliance on iOS. :( :(

@Michael what changed with MIDI sync lately? Can this be affected at all by recent MIDI changes in AudioBus 3? (not used on the Loopy device, but used on second iPad. However, sync doesnt work even when second iPad isnt part of system)

Comments

  • Hey @Diggo - let me check this out and get back to you in a day or two

  • Thanks! I'll keep beavering away on it at this end, testing various scenarios. I'll add to the thread if I discover anything.

    One possibility: might it be possible for Loopy to lose sync if the Lightning connector is finicky? The green charge light is consistently ON and audio isnt breaking up generally, but when observing Loopy's parameter bar (showing the tempo/bar settings) the text/symbol info seems to grey out randomly, which might indicate loss of sync electrically.

    I'll test some other apps which can sync, see if it's more widespread than Loopy. But so far, the symptoms are similar to previous cases when a Loopy update broke sync for whatever reason.

  • It's certainly possible, yeah - if the connection is really unstable, no MIDI clock implementation's gonna get a good fix. But if it's just the software update that's changed thing, then it's more likely to be the update - particularly because this update has a revised MIDI sync engine implementation.

    It was revised to add support for more devices which were not performing well, but it's quite feasible that your device happened to work better with the prior implementation. The solution is to grab a trace from your device and test it out over here so I can see why the new sync implementation's not working as well.

    To do that you'll need Audiobus 3 (let me know if you need a copy); turn on Diagnostic Mode in the system Settings app under Audiobus, and then go into Audiobus, set your device as a MIDI sync source in the in-app settings, and then start the device's clock - Audiobus will be recording the incoming MIDI from it. Because Audiobus has the same clock implementation, you should see the same issues - once you see it, tap "Get Support" in the app's settings to send me the trace. I'll take a look here and hopefully figure out what's going on.

  • OK, that makes sense. The device running Loopy doesn't usually have anything else running - no Audiobus, in other words, but I'll install AB3 and jump thru the hoops you suggest.
    In the meantime, I've already installed MIDI To Link and enabled Link in Loopy. That fixes it i.e. Loopy is syncing fine via Link.
    However, for a few reasons I'd prefer to get the Sync to MIDI Clock function working again as Link gets in the way a bit when switching tempos between songs. We never stop the clock at gigs. Instead, outputs are muted while we select the next "song" in RC505 (The sync master for the entire band). The RC505 contains a few basic acoustic drum rhythm loops we've loaded into each preset, which we use to ease us into each song. Once the new drum bed is playing and tempo changed, we start to unmute or raise faders and we're back in action.

    In other words, once the RC505 starts during setup it doesn't get stopped until the gig is finished. This is the most reliable method we've found to accommodate the changes we need to make when switching songs. We dont have to worry about tempo because that only changes when sync'd devices are muted. (We have a variety of unsync'd sources used to provide audio between songs)

    So it seems the incoming MIDI is sufficiently stable to work well if converted to Link, which likely points to something awry in Loopy when you upgraded the sync parameters. I could revert to an earlier IPA but that's a PITA, so I'll do the Audiobus things you suggest amd report back asap.

    Thanks!

  • @Diggo said:
    In other words, once the RC505 starts during setup it doesn't get stopped until the gig is finished. This is the most reliable method we've found to accommodate the changes we need to make when switching songs. We dont have to worry about tempo because that only changes when sync'd devices are muted. (We have a variety of unsync'd sources used to provide audio between songs)

    To explain further - we have:
    2 x RC505,
    1 x RC202,
    2 x VoiceLive Touch 2,
    1 x Win10 laptop,
    2 x iConnectAUDIO4+,
    2 x iConnectMIDI4+
    1 x iPhone
    3 x iPad

    all sync'd via MIDI Clock from one RC505.

    Works great, as long as Loopy sync is stable.

  • Hi Micheal
    I sent some Support logs from within Audiobus. The final one shows the sync breaking - I loaded Loopy into Audiobus, set AB3 as sync source in Loopy and (not long after) the loop started lagging badly. Hope that helps.
    Thanks!
    Diggo

  • More info: If i insert MidiPace between the MIDI input and Loopy, MidiPace ensures Loopy receives a stable clock.
    Even with stable incoming MIDI Clock, Loopy loses sync (by lagging) after approx 8 loop laps and the lagging gets progressively worse.

    Juxtalooped into the above, I played for an hour tonight with Loopy syn'd to Link via MIDI To Link. Very stable sync!
    But due to preferred workflow, I'd prefer to use vanilla MIDI Clock sync and keep the MIDI To Link option as a backup clocking method.

  • edited June 22

    @Diggo said:
    Hi Micheal
    I sent some Support logs from within Audiobus. The final one shows the sync breaking - I loaded Loopy into Audiobus, set AB3 as sync source in Loopy and (not long after) the loop started lagging badly. Hope that helps.
    Thanks!
    Diggo

    Hmm, nothing shown up here yet. Is your email on the device setup right? Nothing still sitting in your outbox is there?

    set AB3 as sync source in Loopy

    Wait, could you tell me more about that? I was expecting you to just use Audiobus on its own, receiving from your hardware, under the assumption that the signal from the hardware was what was giving the MIDI system trouble. Did you experience the same lag with just Audiobus' own internal MIDI clock going into Loopy?

    What happens when it's just Audiobus on its own (no Loopy) receiving clock from your MIDI source? Does it lag too?

  • A note to say Michael worked throughout his injured eye recovery to solve this edge case, which was causing Loopy to lose sync at recording punch-out if slaved to MIDI Clock and initial (first) loop duration exceeded 8 bars (i.e. a large number of MIDI beats).
    Circumstance = no pre-set bar length (always set to 1), instant punch in/out via external controller.

    Now it is fixed and so is Michael's eye. Good times!

    I'm guessing a new release iteration will be in the App Store sometime soon.

    Thankyou Michael!!

  • Hi Michael
    Unfortunately, I have to report this problem isn't fixed (or something has reverted in subsequent update)
    I've sent you support emails from Audiobus and followed that with emails linking to a video adn audio sample I made to show the problem.
    It seems to be a calculation problem, whereby Loopy calculates the tempo to be slightly slower than it is, which causes the duration of the final beat to be truncated, thus throwing all the beats out of whack when I punch out.
    This happens no matter which settings I use, including automated punch in and out (via count in and count out)
    Something isn't right in the MIDI Clock averaging algorithm?
    Using MidiPace to clean the MIDI Clock prior to input to Audiobus and/or Loopy doesn't fix the problem, which again seems to point to a tempo algorithm going awry when Loopy is slaved to an external clock. Same when using MIDI To Link.

    On another note, I can't get Loopy to respond to Start & Stop messages when using MidiPace or MIDI To Link.
    Setting "Use Start & Stop with Link" in Audiobus doesn't seem to work with Loopy when slaved.

    Thanks!
    Diggo

  • (Note: we worked through this via email, sorted now)

Sign In or Register to comment.