Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has been closed down.

Freezes, crashes to background, yikes!

edited September 2012 in Support and Feedback

Hi. I really dig Loopy HD, but am having some issues which are preventing me from using it live - I have the startup bug, and am forced to delete the autosave every time, but even worse it often becomes frozen, unresponsive, until suddenly all the button presses initiated since the freeze all hit at once (which is always a mess). Often when it locks up, I have discovered that plugging things in/out, of either the phones or dock, will bring the responsiveness back.

I use the program in two ways, on ipod touch 4th gen: with my "Kaossturbator", midi synced to a Kaossilator pro/KP3 looper setup with an irig midi dongle, Loopy loaded with drum beats to mix and match, & velcroed to my "Podcaster" guitar, doing audio looping and drum loops with Thumbjam and guitar into a mini mixer, then Loopy via an Ampkit Link audio jack.

I have great fun pulling these things out at your basic open mic type places and blowing minds with all the marvellous noises, but it has managed to freeze up the last few tries, and I will unfortunately not use Loopy again in public if this sadness persists! Any assistance you can offer would be most welcome, thanks, Mike.



  • Hey Mike - I'm very sorry to hear that - that sucks. That said though, I'm pretty sure I've fixed all of these issues in the next update, which is going to hit the App Store any day now. It's been waiting for review at Apple for a week now, so it'll be out any day.
    Let me know how it goes once it's out - if there're further issues, I'll sort them out.

  • Terrific! I am very happy that this'll get sorted. You have created my favorite software ever, it is really a joy to use, and the finest looper I have ever known! I have been looping since 1992, and have used the Lexicon Jam Man (best midi implementation still), the EHX 2880 (good midi but rather inflexible), the Boss RC-50 (pure frustration), and Ableton Live (beyond great, but quite elaborate in terms of the hardware required), and I must say that Loopy trumps them all for immediacy and fun - it is powerful, user friendly, and quite elegantly designed. I am very grateful for your efforts, you should be very proud of the joy you have brought to all us happy loopers! Be happy, have fun, and thank you! Ciao, Mike.

  • Thank you so much! That's really lovely =)

  • Should be all fixed now. Let me know how it goes.

  • Hi .... I am a novice just got iPhone for first time and have loved playing wih loopy . However it keeps ,after a few days failing to load ? Not freezing like this fellows I have been importing from bassline, chordbot and a synth program (name escapes me ) . Just wondering if there is something basic I am doing wrong ?

  • Can you be more specific, @Zewsky? I'm afraid I don't quite understand what's happening.

    Also, just to be certain: You have upgraded to Loopy 2.4/Loopy HD 1.3, right?

  • Hi Michael. I love this app, Would love to be able to use it live- in the middle of a dj set without having to lug along the RC-50, and maybe even replace the RC-50 all together! However I have a real freezing issue. I can start the app fine but just as soon as I hit record first time, app freezes and I stop hearing myself through headphones. The ball I tap goes white and then nothing. I close all other apps but still no luck. Any idea? I'm using a first gen iPad. Cheers!

  • Thanks Alex!

    Ah-ha - this sounds like it may be another incarnation of http://forum.loopyapp.com/discussion/754/new-iphone-verison-bug

    I'd dearly love to be able to replicate this myself; what's your setup? Any hardware plugged into the iPad 1? What iOS version? Are you using Audiobus with it, or just Loopy alone?

    Finally, would you use the in-app "Email Support" facility in Help to send me some diagnostics?

  • I have a similar issue. It happens especially when I have my guitar plugged in via USB. It makes a bunch of high frequency sounds and then I can't hit any buttons. Crashes to background.

  • What hardware're you using @ejbigelow?

  • Just received my io dock and tried loopy out with just a mic. Worked fine first time but after resetting the session a few times the trouble started. Emailed you the report. Wasn't using audiobus but I'm hoping to. I'm on iPad 1 with iOS 5.1.1 (iPad 1 doesn't upgrade to ios 6).


  • Would you guys try the new version? Hopefully it's working a bit more robustly.

  • Hi,
    I'm new to recording multiple tracks, overdubbing and the like. After reading some great reviews about Loopy HD, I decided to give it a try. However, after downloading and installing it on my iPad 3, it freezes immediately after loading. I have tried waiting several minutes after the initial screen appears to see if it just takes a long time to load, but have had no success. I'm hoping you can help. Thanks.


  • Just updated on my ipad 1, immediately crashes to background!

  • I updated this afternoon and han't tried it until i just read about all the crashes. So I fired Loopy up just now and it loaded fine as a standalone app on an iPad 4. (I just tried starting it, not recording anything as I've just gone to bed. )

  • Updated and got the same problem as @Ginestasjack - opening screen then crashes to background.

    Before updating it had good and bad days, yesterday it was working fine non stop.

    Shame I was getting to know it a bit better. Hope you can fix it soon!

  • Hi
    I just buy Loopy HD .
    It chrashes at start on my ipad 1 :-(

  • Hi, i havé an Ipad3 but stil using iOS 5.1.1. Just upgraded this morning and while starting it, after the opening screen it crashed to background.... Please need fix I'm playing live next weekend.

  • Hi guys - are all of you using iOS 5? I've just discovered one of the new VoiceOver accessibility features is iOS 6-only - one of the hazards of the current development environment is it never warns you when you're using functions that aren't supported in prior versions. This might be it.
    I'm going to race the next update out, anyway.

  • @Alterego - I'm gonna do an expedited review to get this out ASAP, so it should be just a couple days, but if it's longer and you're in a bind, let me know directly (michael at atastypixel dot com) and I'll see what I can do about helping you out.

  • Yeah I'm on 5.1.1 as iPad 1 doesn't get 6. Does it work fine on ios 6 devices? If so that may be the problem. I won't pretend I know anything about how to alter this stuff haha.

    Cheers for you responsiveness though, I'm not giving up on loopy yet!

  • It's most definitely the problem, and a fix is en route: http://forum.loopyapp.com/discussion/823/known-issue-crashes-on-ios-5

    Very sorry for the hassle!

  • Wow, excellent support!!! I was keeping my iPad prior iOS 6 for google map... But I guess I need to update. However let me know if you have the fix. To derisk the gig I'll likely update to its 6 but ... Please continue you great work, your software is excellent and super easy to use.

  • Cheers @Alterego =)

    Yeah, Maps is a problem - mind you, you can install Google Maps on it; the one hitch is that Google Maps is designed for iPhone only, so it isn't iPad native.

  • edited May 2013

    I hope the coming update does indeed resolve the issues. My iPad 3 is running iOS 6.1.3 and I'm having the crashing/freezing issues. In fact, I just attempted running Loopy again and it froze immediately (as before). However, this time, I could not close it and had to restart my iPad to clear it from memory.

    Update: I decided to try running the 1.4 version of Loopy HD on my iPhone 4 with iOS 6.1.3 and it ran flawlessly. Why would it run without problems on my iPhone but not my iPad? I'm only guessing, but could there be a conflict with the display on the iPad 3?

  • Hmm, would you be able to email me your crash logs from the iPad 3, @Diffie? Here's how: http://atastypixel.com/support/crashes

  • edited May 2013

    I will try to do this. I will tell you that I have had difficulty in syncing my iOS devices with my computer (Windows 7 64bit) because of some incompatibility with my setup. I am constantly receiving a message about not being able to load data class information or something similar. I have reset my devices several times, but iTunes returns the same message. Syncing my devices seems to be the only problem. I am still able to download updates, new songs, podcasts, etc. with iTunes on my computer by going to the proper section (Music, Apps, Podcasts) and downloading them. However, syncing calendars and other information has become almost impossible.

  • Michael, do you know if there is another way to view crash logs other than syncing the device with a computer?

  • Ah, damn - that's a shame! No, I'm afraid that's the only way - aside from reporting crashes from within the app itself, which might be tricky if it doesn't launch.

    The update has just entered review, so it should be just a few hours now, then we'll have a moment of truth. I hope it will address your issue - if not, I'm going to have to go back to the drawing board, I suppose!

    I'd enormously appreciate seeing any crash logs, if you do manage to get synced up (Maybe remove & reinstall iTunes)

  • YES! YAY! HIP HIP... HOORAY!!! Loopy HD is working flawlessly on both my iPad and iPhone! I'm through the first two tutorials with no problems. Thank you very much for the app and your follow-through. Very best wishes on your continued success, Michael! :)

Sign In or Register to comment.