Loopy Monitoring Selector: Mics vs. MIDI Controller Conflict

edited May 6 in General

I'm struggling with a seemingly intractable problem.

I'm running two microphones and a MIDI controller into Loopy at the same time via Audiobus. The MIDI controller is the Lekholm DM48 MIDI harmonica, which I'm playing through wind synth patches in Thor. The two mics are plugged into the Zoom U-24 audio interface. The DM48 and Zoom are plugged into a USB hub, which is connected to my iPad Mini 4 via the Apple USB to Lightning connector. I'm able to get them all into Loopy via Audiobus 3. So far so good...

The problem arises with the Monitoring selector switch in Loopy (just under the Reverb slider). To hear the DM48, I have to have Monitoring switched on. Without it on, I can see the signal coming in but can't hear anything. However, having Monitoring on is bad for the mic sound: you hear a slap-back echo, and it's easy to get feedback. Switch Monitoring off and the mics sound great. But then I can't hear the DM48...

Of course I can get around this by switching Monitoring on and off constantly in Loopy depending on whether I'm using a mic or the DM48, but that is a real hassle. Not only that, it seems inelegant and, I hope, unnecessary!

This is my first time trying to combine a MIDI controller playing through an app with mics via Audiobus in Loopy, but I assume many others must have done something similar before me. I'm sure Michael has built in a simple solution for this apparent conflict to do with Monitoring which I haven't sussed yet. Can he or anyone please help? Thanks!

Comments

  • To be succinct, what I'm after is a way to hear the DM48/Thor app sound in Loopy with Monitoring turned off. Is it possible?

  • A lateral method that I wonder about: could I hear the DM48/Thor sound via a different route even though I'm not hearing it in Loopy with Monitoring turned off? Since I can't choose Thor twice as an input in Audiobus, maybe by selecting it as input in AUM instead, or in addition to Audiobus? If I could hear it via the speaker output in AUM even though it's silent in the AB-Loopy connection with Monitoring off, that would be fine. Or is this nonsensical?

  • Just did more experimenting - it's worse than I thought. If I record a loop with the mic with Monitoring off, then turn it on so I can hear the DM48 as I play it, the RECORDED loop gets that same hollow ring as if I just put sounds though the mic with Monitoring on... Bummer!!

    From this it appears I simply can't use Loopy with mics and Monitoring on at all, which means I can't loop with mics and the DM48/Thor at the same time. Really???

    Please can one of you experts chip in and tell me I'm being an idiot, and it IS possible after all with some simple setting I've overlooked.

  • Well, I'm not getting much traction on this thread...! Anyway, I've kept experimenting, trying everything I can think of. For anyone who might be interested, I've found a partial solution.

    In Audiobus I had the DM48/Thor as one input, and the two mics in the Zoom U-24 as the other, L+R. Both were routed to Loopy. In that setup, I had to have Monitoring on to hear the DM48 in Loopy, with the consequent bad sound on the mics described earlier. Today by chance I deleted Loopy on the Thor channel in Audiobus, and chose no output at all. I could still hear the sound from the DM48/Thor. I opened Loopy and, hey presto, I could still hear the DM48 and record with it with Monitoring off. I could still record with the mics too, with the clean sound. At last, I thought!

    Not so fast... I went back to Audiobus and noticed in the Mixer section that the Thor signal was now leaking onto the Mics channel. No amount of panning or selecting just the left or right channels in the Thor output/mics input would change it. It means that when I lay down a loop with the mic and then record another with the DM48/Thor, the mic loop gets recorded too, though a bit quieter. I can mute the orginal loop but still hear it on the Thor loop.

    It's not a perfect outcome, but it's better than what I had before. With Monitoring off in Loopy I can now hear the mics and the DM48, and record with them both. Questions now are:

    1. Why is there leakage from the Thor channel onto the mics channel in Audiobus?
    2. If I fix the leakage somehow, can I still hear/record Thor in Loopy with Monitoring off?

    If there's anyone out there who might know the answers, I'd be glad to hear from you. Cheers, BeePee

  • Hey @BeePee - sorry about the delay, I've been a bit crook and off work. Back again now and slowly getting through my inbox =)

    Ah, that's a tricky one indeed - because Loopy just treats input from Audiobus as a single stereo stream, it can't treat them separately (providing monitoring on one source, and not on another). I'm planning on removing the single-output limitation in Audiobus shortly, however, probably in version 3.4.1, and that will solve that issue, as you'll be able to have monitoring off in Loopy, and select an additional audio output for Thor.

    As for your workaround - are you certain the leakage in question isn't just acoustic, because the mics are picking up the audio output from your speaker? (if that's the case, you'll need to address that feedback loop if you want to do any looping - google 'audio feedback loop live-looping for examples)

  • Sorry to hear you've been crook Michael. I'm a Kiwi living in the UK, and they don't use that term over here, nice to hear it again :-) Glad you're better and thanks for the reply, much appreciated!

    That update to Audiobus 3.4.1 to give discrete outs sounds excellent, looking forward to that.

    The leakage is happening with headphones as well, so it's not acoustic. All my mics are handheld with volume controls, and when I play the DM48 through Thor the mics are turned off. I think it's some USB issue to do with the TC Helicon Voicelive Touch that's in the signal pathway after the mixer. I'm getting different behaviour when I use USB in to the iPad as opposed to the iRig headphone input. It's a different issue to the one discussed here so I'll describe it in another thread.

  • I found a solution. In the Vocelive Touch settings menu, you can choose three different USB modes: Stereo, Track, and Insert. It was set on Stereo. I changed to Track, and now the leakage has disappeared. I still need to turn Monitoring on to hear Thor, and it's best off for the mics, but that's a quick switch. The loops are no longer bleeding onto each other. Result!

  • @BeePee said:
    I found a solution. In the Vocelive Touch settings menu, you can choose three different USB modes: Stereo, Track, and Insert. It was set on Stereo. I changed to Track, and now the leakage has disappeared. I still need to turn Monitoring on to hear Thor, and it's best off for the mics, but that's a quick switch. The loops are no longer bleeding onto each other. Result!

    Wow, okay cool. Still don't quite understand this one but as long as you're happy, I'm happy!

Sign In or Register to comment.