Why not have “Reduce latency when monitoring” setting like Ableton?

I like many others struggle with using this app due to latency. However, if there were a setting similar to Ableton’s “reduce latency when monitoring” setting, I think that would solve it 100%. Basically, have the loop recording make up for the latency by compensating the delay on the play time of the loop. I dont see why it couldn’t be done both when monitoring the input or with the monitor set to off, but anyway you could get it to work would be amazing! I’d love to be able to sell my rc505 someday... Great effort and fun app so far though!

Comments

  • There is no latency issues at all for me when I use Loopy. Thanks to Loopy I don’t have the slightest interest in buying a hardware looper like the rc505 :-)

    Let’s see if we troubleshoot what you have going on. Are you talking about actual audio latency for monitoring your live input? Loopy can be set to 64 or 128 frames for hardware latency which is not perceptible and works fine for live performance.

    Or are you talking about getting your loops synced as you record multiple separate tracks? You can turn on tracks to synchronize based on a set BPM or sync to the first loop. This works perfectly in Loopy and makes it really simple to record perfectly synced loops.

  • I mean, there is some. By nature of what I am doing, there is always going to be some unless it is accounted for and corrected in the app or DAW I am using. Anytime you convert AD/DA, there is going to be some latency no matter how small due to the conversion time, and I use external instruments, so there is a conversion when I go to loopy. It might not be noticeable for guitarists or keyboard players that play chords, but as a drummer, it is absolutely noticeable when it is the slightest bit off. I have set the frames to the minimum they can go, and it is still audible.

  • Ah I see what you are saying. I think in general I have to set a first loop that can be a metronome then everything else always syncs up. Tighter percussion elements are definitely the place things can be off. Does a hardware looper not have this issue? There is AD/DA conversion going on there too, right?

    Also I’m pretty sure Loopy compensates for that already, I seem to recall a few app updates where it was slightly off, then fixed later... @michael, do you have any input on what is going on for latency compensation?

  • Please excuse the delay gents. Are we talking about a differential between the monitored audio and the loop playback? I just tried that (with two Loopy instances on separate devices synced up - the first playing with a metronome, then on the second I record a loop of that metronome), and there is a very slight flam audible, which is to be expected due to the round trip delay of the monitored audio. I suppose I could add an option to introduce an extra delay to the loop playback to match the monitored audio. Would that be helpful?

  • Thanks Michael, I don't know for sure but I think that is exactly what SoundNerd is talking about.

    Am I right that there has been this sort of feature built into Loopy in the past? I seem to recall that when a loop was recorded, it has a tiny offset so that it matched the monitored input.

  • Yep, that is precisely what I am requesting! I know the latency is very minimal, but as a drummer, it makes a different with hi-hats and snares. If there was... I don't know about a delay, because the loop playback would need to move up, not back... But if there was a way to make the loop compensate for the latency, that would be amazing.

  • And I guess I am not talking about a difference in the monitored audio... In my set up, I would have my instrument going dry direct to the mixer/speakers, as well as to Loopy. In loopy, I don't have monitoring on, so there is no sound coming out when I just play my instrument. I only use it to record loops, and playback loops. My dry signal continues to go straight to the mixer (as well as to loopy, but it is muted in the app), and is heard without being processed by the ipad/loopy. So the compensation I am talking about would be for the dry signal prior to it being sent to an ipad and the loops recorded in loopy.

    Hope that makes sense, but I can try to clarify further with illustrations and further explanation if not. Thanks!

  • Ah! That makes a lot more sense, @SoundNerd - but raises a new question, which is why it's not working for you already. Loopy already does exactly this latency compensation, using the reported latency from the hardware to alter the time offset so everything lines up. I just tried it to make sure it hasn't stopped working mysteriously, and it's working fine:

    https://youtu.be/7OCx8T7r344

    So, the question is what's going on with your setup. Are you in a position to try the above for yourself, with and without your audio interface? Curious to see what results you get. Might need to do some digging.

  • Really?? That is awesome that it was already considered and is already there! Now I will have to solve the mystery of what in the heck is going on with my rig... I cant check it out right this second, but I will try to set loopy back up in my rig and give it a go this week to see if I can figure out where my problem is. Basically I am running into a Line 6 Helix Floor effects unit, and using the USB to go into an ipad. Maybe it is something with the Helix that is caused the delay issue. If I can get this figured out, I will report back with my problem/solution. Greatly appreciate your responses, and again, all the hard work on a great app! I've always had fun looping my ipad synths on it, but its going to be a game-changer if I can really get this to work with my external instruments. Thank you for taking the time!

  • Got to test for a little bit last night, and holy cow, everything was working with zero, and I mean zero, audible latency. I was running a crisp 808 drum loop into Loopy via my Line 6 Helix Floor's usb in/out, and there was no flam or delay whatsoever from the live signal when compared to the looped track. Not sure what I was doing or had setup wrong when I tested a few weeks ago and got that lag I noticed, but I cannot even tell you how much this makes my day/week/weekend/life! Super excited to dive back into loopy full throttle! Thank you so much again for making such an amazing app, and for all the patient and considerate support you provide! I don't know what else you can do in the upcoming Masterpiece Edition to make me happier with an ios looper than I am right now, but I am fully back on board with Loopy and excited for that as well! All the best, sir!

  • That's great news @SoundNerd! Lovely to hear. My guess is just a hardware/system glitch, it happens sometimes. If you see it again try unplugging and replugging or power cycling the interface. I have a Focusrite interface that does that sometimes, with about a half second delay. Needs power cycle then it's good.

Sign In or Register to comment.