Help. Midi Sends Not Functioning

Hi folks, I'm hoping to find some assistance here.
I am using a Keith McMillen Softstep 2 into Belkin powered usb hub into an iConnectivity Audio 4+ with an iPad Air running Loopy HD. There is also an Akai MPK Mini in the mix, same routing as Softstep. I have had all my midi bindings set for a while and they have been functional. Suddenly none of them work. I did not change anything. Weirder still, if I click "Add Binding" Loopy HD recognizes my midi controllers (both Softstep and MPK Mini) and I am able to recreate my bindings from scratch. When I try to then use the controllers to control loopy, they do not work, as if Loopy is not receiving the midi sends. Has anyone experiences such a problem? Any advice would be helpful. I am trying to set up a live looping rig and stuff like this is a deal breaker.
Thanks so much!
Sasha K

Comments

  • Hey Sasha - just to make sure we've covered the obvious: Have you selected the source in Control Inputs settings? It should have a tick beside it. If not, tap the source.

  • edited June 14

    Hi Michael,
    Thanks so much for the response. I have indeed selected the source. I have actually tried with and without the 'tick' as I have basically been trying everything in attempt to get this working. If there are any less straightforward suggestions, I am open to trying.

    Btw, this mystery issue aside, your Loopy HD app is amazing. I've been live looping for years and this has opened up a world of creative potential previously only imaginable. I'm really excited for Loopy Pro whenever it should arrive. I have built an entire rig around Loopy and once I've ironed out the kinks I have confidence it will be my setup for the indefinite future.

  • Ah well, it's never that easy is it? =)

    Just making sure I get what's going on here: none of the actual controls work, but if you open the Add Binding screen and hit a pedal, you see the MIDI note show up on that screen?

    Thanks heaps for the kind words, that's great to hear!

  • That is precisely the issue. When I go to Add Binding the midi note shows up on screen and I am able to save it. Then when I try to use my midi controllers it's as if they're not connected.

    This started seemingly spontaneously two days ago when my bindings just suddenly stopped working. I am able to use the same primary controller (Softstep 2) in the same setup with the Bias Fx and Amplitube apps. I can bind and then use my bindings. So, it doesn't appear to be a hardware issue.

    I have also tried running Loopy HD in audiobus and by itself. Same issue either way.

    Weirder still, I tried uninstalling and reinstalling Loopy HD and I still have the problem. Incredibly peculiar. Sorry for the headache. I appreciate you taking the time to personally assist me.

  • Yikes, that's weird. Did you update Loopy recently? Trying to work out if this is because of a change I made, or whether it's unrelated...

  • Hi Michael,
    I just got home from work, plugged everything in, and BAM! Problem spontaneously solved. Please don't stress yourself out on this one. If this happens again I will certainly be back on here. Hopefully it was just an unexplainable one off occurrence. Thanks again for being so prompt and troubleshooting with me. I'm off to do some looping.
    With gratitude,
    Sasha K

  • Wow! Okay, good :) Hopefully it'll stay fixed!

  • Hey Michael,
    So I hate to be that guy, however this issue resurfaced again 48 hours later. Are you aware of any compatibility issues between Loopy HD and either the Keith Mcmillen Softstep 2 or the iConnectivity Audio 4+? I would love to figure out what is going on.

  • What the! Hmm... could it be sending messages on a different channel, somehow? No, I'm not aware of any compatibility issues!

Sign In or Register to comment.