The iPad Air 2 timing issue has returned!

I had almost forgotten about the bug where when you first started loopy and plugged in your sound card there would be a delay on playback, attributed to an ios issue. It had been months since it had happened to me. With the current beta, it now not only is the latency there, but the work around of stopping loopy, unplugging the interface, starting both again, fails. Unless you do it twice! then it's ok. Consistently have to do it twice. Anybody else seeing this?

Comments

  • Hey @panmanphil - by 'current beta', do you mean iOS beta, or Loopy beta? If the latter, does that mean the App Store version is fine?

  • Current testflight beta of Loopy HD with IOS 9.3.2 is what i was reporting on. I've since just updated to IOS 9.3.3 and will try it out with Loopy tonight.

  • How'd you go, @panmanphil? Still seeing weirdness? What about comparing App Store version with Beta?

  • No change with ios 9.3.3. I am gigging with it tonight, won't switch to the app store version until after the gig, but should be able to try then.

  • Hmm, I can reproduce this too, but I can also reproduce it with every other app I tried that takes mic input.

  • This IOS issue is becoming a nightmare for me. On the gig, the first tune I did was fine. Then the ipad was locked for about a set before doing another looping session. Then with eyes on us, the latency was back and the tune that combined a pre-recorded loop with live looping sounded silly at best. It sounded honestly like somebody had hit a skip button and slid the pre-recorded loop forward each repeat. I had to apologize on go back to just guitar and voices. I still hope to try again with the latest beta, but have some other commitments going on tonight. I'll report as soon as I can. Doesn't sound like there is much you can do anyway if it's an IOS bug.

  • What's your audio hardware, @panmanphil? I'm going to write to my contact on the Core Audio team at Apple about this.

  • I get a similar issue using Loopy with a Line6 sonicport VX, Puc+& Bluboard.
    If I start up the bluetooth midi device apps first and then Loopy HD last, everything works fine. Usually.

    If I don't - or if have Loopy open even by itself with the audio interface plugged in and maybe unplug or plug it back in - the loops being recorded may be a bit off. This is of course usually when an external controller is used to trigger the loop. I must then restart Loopy.

  • I decided to bail and not use Loopy for my last couple of gigs. Just too unpredictable. Michael contacted me offline, and when I tried to reproduce it, it worked every time. Today, the problem returned in a test with IOS 9.3.5. I've got a month or so between now and the next gig I'd likely use it so I'm going play with other apps too, because I really don't believe this is a problem Loopy can solve. Just maybe with more info some solution can magically present itself

  • That's horrible - I'm very sorry to hear that. I'm a bit stuck as to what to suggest - it's definitely sounding like a problem at the junction between hardware and OS, but this has been an issue on iOS on and off for the last year or so, with certain hardware. One thing to perhaps try is to post about it on the Audiobus forum as well - could be someone there's seen it too, and the more info the better. I'd also like to hear results from other apps, to see if the problem's there. Sometimes one of us developers stumbles upon a workaround, a particular startup sequence or some audio session mode, and it solves it.

  • Reviving an old thread just to say that somewhere around IOS 10.2 updates, or possibly something else because there is more than one thing in play with this, my latency issues on the Focusrite + iPad Air 2 have disappeared. Well other than skill at hitting my midi footswitch while singing and playing the guitar. More an more it is becoming a part of my gigs. I haven't ruled out getting a Surface running Windows 10 yet, but the draw is diminishing a bit again now.

  • Oh good!

Sign In or Register to comment.