Midi Commands Not received - Midi "learn" issue?

Hello All,

i just donwloaded and installed LoopyHD v 1.6.1 (Italian) on my iPAD AIR with IOS 9.3.2.
I would like to manage this SW with my Behringer FCB1010 (that i already use for other applications, and i that know how to configure).
Usually, my MIDI/Audio Interface is the RME FF802 connected to a MOTU MIDI EXPRESS XT (Where all my other instruments are connected to) on one side, and to the iPAD via the Camera Kit -

Midi Instr. <-> MOTU midibay <-> RME <-> iPAD

All the applications on the iPAD work flawlessy with this configuration (Nave/Sunrizer/Garageband/Cubase/iPolisix..), all i have to do is to select the RME interface as their MIDI port.
The FCB1010 is being used to Change Programs on these applications also.
So, all in all everything works fine.
Loopy is configured to use the very same MIDI interface.

When i try to bind midi messages (notes or PC's), Loopy simply "waits" as nothing happened.
I tried to synch Loopy with an external MIDI clock, with no success.
I tried to synch a synth with Loopy as a master clock, and it worked.
So, my guess it is that the RME is recognised and used; but still, nothing.

Then, i got rid of the RME/MOTU configuration, and i connected the FCB1010 straight to the iPAD using the iRig2 midi port.
And again, all the other applications worked fine, but Loopy; which i configured to use the iRig2 midi port, of course.
So, it's not an Interface/MIDIbay problem, i think.

In only one occasion, midi commands have been recognised with the iRig2 configuration (i did nothing special, just pressed some buttons on the pedalboard, PC's had been sent), then suddenly i saved the binding to check whether it worked - it didin't and worse, the binding disappeared completely as if i never did it.

At this stage, i cannot tell what's going on, as everything else works fine in any configuration.

Any hint?

Regards,
Matt

Comments

  • When you work with midi through another app you do need to tell Loopy where to get it's midi messages from, either your hardware interface or the app. I found that having something really visual to tell me it's working is great like select next track. But to just get it to work, you should be able to select the correct interface and see the messages right in the screen to bind a command to a midi message.

    Have you selected the interface? do you see anything in the binding screen?

  • Hi Phil,

    the simplest test i did has been to connect my pedalboard to iRIg2 Midiport, then i selected iRig2 (ONLY!) as the midi interface for Loopy, no other applications invoilved, nothing.
    No midi data received at all by Loopy.
    With this configuration it worked once though, but I did nothing before it worked, and nothing after (no reboots or similar) : i just tried another binding and it worked, just to stop forever again : binding in wait for midi data..

    All other applications work perfectly with this configuration, and they work with the more complex one also - (RME / MOTU): i can either play notes, or send PC's to change patches from any midi device connected to the MOTU.
    For example i use a KORG 01/Wfd as my main keyboard to play Nave/iPolisix, or i can MIDI synch all the devices (iPAD appls included) with my Motif, and so forth.

    Thanks for the hint anyway!

  • edited July 2016

    Hey @graafzeppelin - Bugger! I'm having trouble reproducing this with the setup on my end; what do you think about trying a diagnostic build? I'll need you to email me your UDID (michael at atastypixel dot com), then I'll make a build and send you the link with further directions.

  • HI Michael,

    thanks for the support! UDID sent.

    just to be precise, binding worked only once with this configuration (Loopy only running on the iPad, and configured to use the iRig port only) :

    iPAD <-> iRig2 Midi port <-> FCB1010

    binding has not been saved though, in spite of the fact that i did save it.

    same exact configuration, I switched Loopy off and lunched Nave/iPolisix/Sunrizer, then i sent midi notes with the fcb1010 and Nave played the notes.
    Then, with a different FCB1010 bank, i sent program changes, and Nave patches changed accordingly.

    I tried to repeat the Binding several times, but it didn't work anymore.

    With the more "complex" configuration (iPad - RME FF802 - Motu - midi instruments : the config that i'd like to use actually), all the other applications work.

    Thanks again!

    Cheers,
    Matt

Sign In or Register to comment.