Loops won't restart while I'm recording

I have been practicing my music with Loopy every day for the past four months, and this has never happened before, and I'm positive I haven't changed any settings. I have the loop length set to four bars, and I have it set to overdub after record, which means I should start playing along with the looped audio after four bars. But suddenly today, the loop won't restart no matter how long I play. I can see that the loop is highlighted and it's clearly recording and filling up with audio, and if I stop playing I can see it filling with silence, but it never restarts! I even tried decreasing the loop length -- I can bring it down to a single quarter note and then I can sit there and record for 50 bars without ever hearing it come back to the beginning of the loop.

This is baffling. I keep thinking, what if this had happened during a live show??

Comments

  • @Explodey - I just tried it and it works, but I can't say if it has changed with recent updates, as I don't use the "Overdub after record" normally. Hint: the indication that it will automatically stop recording, is the moving bright spot a long the outer edge of the circle. If ther is't one there when you start recording, it idicates that it will need to be manually stopped.

    My settings in Track Management are:

    -Overdub after record ON
    -Synchronization ON
    -Count-in recording ON
    -Count-in quantize - doesn't affect the "Overdub after record" on the first track, but will affect subsequent track count-in.
    -Count-out recording Enabled

  • Thanks for your reply @Ganthofer . There definitely is not a bright spot moving around the edge of the circle. How do I get it to come back? I don't see anything in the settings about whether or not I have to manually stop recording.

    Anyway, I appreciate your help, but I have gone through all my settings again and again, and everything is definitely as it should be. I am truly at a loss. I've got a video shoot coming up with my looping performance, and I don't know what to do.

  • @Explodey - the settings I listed above are the minimum required to make it work, along with setting the tempo. But you must be setting the tempo or you wouldn't be able to set the number of bars (clock multiplier).

    This is strictly for the first loop, yes? Or is this on a loop after the first one has already been recorded?

    What version Loopy? What iOS version?

    Did you update loopy recently ? Do you remember when the last time was that it worked correctly? Loopy just got updated a day ago. I have the last few versions of loopy backed up and could try the previous version if you can describe the exact work flow, step by step so that I'm sure I'm reproducing it.

  • Also, just to make sure, do you definitely have Count-out recording Enabled, @Explodey?

  • Happened to me as well....testflighting the app... Does it have anything to do with that?
    Michael, I sent you this through the testflight feedback

  • Interesting! Thanks for the extra info @taldavid. I'm going to look into this today.

  • Would you both (@taldavid and @Explodey) be able to email me using the "Email Support" feature in Loopy, under Help? That'll include your settings so I can check. I just tried to reproduce the issue here, and everything's working fine =/

  • @Michael I played around with my settings some more, and I was able to solve it by enabling "count-in recording." I guess I should have looked a little more closely at the list of settings that @Ganthofer provided. But I still don't understand why this suddenly happened, because I disabled "count-in recording" over a month ago, and everything was fine until the day before yesterday. Is that when Loopy was updated? I think my iPhone is set to auto-update. Looks like I'm using v1.5.4.

    Btw, the reason I disabled "count-in recording" in the first place was because that was when I started using Ableton Link, and Link does its own sort of count-in. So whenever I would start recording my first loop, I was getting two count-ins in a row.

  • Ah, that's weird!

    I'm going to update Link shortly (not the immediately upcoming update, but one following that), and will check that double-count-in issue.

  • @Michael yes, same here about the count-in just like @Ganthofer wrote. Wasn't a problem before....

Sign In or Register to comment.