Are people still having problems with recent iOS bugs?

Hi, I'm not sure the best place for this question so I'll try posting here and in General.
For months I've been considering the best looping solution for me and the more I learned about possibilities with Loopy and AudioBus, and, well a few days ago I was all set to invest in some gear, almost. At the last minute I came across problems people were having with recent iOS releases and it took the wind out of my sails. I was very sad. It makes investing in this otherwise awesome platform feel very risky, and makes me want not to support Apple.
I've gathered: that Apple has addressed some of the bugs but there are still some people having trouble;
That some people have found a reliable work around involving the headphone jack.
I guess the sensible thing to do at this point is to wait and see if Apple moves in ways that lead me back to feeling like it's not a risky investment, yet I feel a sense of urgency since I have a performance coming up and my plan called for a looping solution.
The rig I had in mind was iPad Air 2 64GB, FocusRite 2i4, FCB1010.
Thanks ahead for any advice.

«1

Comments

  • don´t hesitate. i started ipad music about two years ago and had a hard road to go (bugs and so on). but there´s nothing comparable if you want to have that much stuff in one place to carry around ( ipad ) and play music wherever you want. the air 2 and fcb 1010 should be ok. but i would go for this one:
    http://www.thomann.de/gb/native_instruments_komplete_audio_6.htm
    instead of the focusrite.

  • @owi. This looks like a pretty complete interface but I'm not sure how the iPad will connect. Do you use a lightening to usb cable for input?

  • i would reccomend this one: http://www.apple.com/shop/product/MK0W2/lightning-to-usb-3-camera-adapter?fnode=37
    it works with ios 9 and charges your ipad. i don´t know if you will need a powered hub connected to the adapter (above) because i don´t know how much power is required for the interface. but i think it should work without a hub. i received the adapter last week but couldn´t connect it to my air1 because it´s on ios 8.4.
    i´m waiting for the new release of ios 9.3. that might happen in a few days i hope.
    i had the interface some weeks ago for testing and was impressed about the straightforwardness.
    but in the end i switched to the iconnect audio4+ which charges the ipad. that was before the above adapter was released (charging the ipad while connecting usb gear).

  • owiowi
    edited March 2016

    @michael, sorry that i´m going to break peace

    but i found that loopy hd/loopy doesn´t sync

    well with linked apps after the update to ios

    9.3:

    yesterday i updated both my ipads air1 from ios

    8.4 to 9.3.
    all apps on both ipads are latest versions.

    i made tests with apps that use link (fugue

    machine, drumjam, patterning, loopy hd, loopy).

    the usb audio/midi interfaces:
    iconnect audio4+, focusrite scarlett 18i8,
    behringer uca202.

    1. test = wifi (very stable connectivity)
      with both ipads:
      ipad 1 and 2>ica4+ (ipad1=audiobus>input1>loopy hd)
      (ipad2=audiobus>input2>loopy hd).

    2. test= wifi
      ipad1 ica4+ (audiobus>input1>loopy hd)
      ipad2 uca202(audiobus>input2>loopy hd)

    3. test = wifi
      ipad1 scarlett18i8 (audiobus>input1>loopy hd)
      ipad2 uca202 (audiobus>input2>loopy hd)

    4. next tests: the whole thing without audiobus.

    5. next: only ipad1 with loopy and loopy hd (without wifi)

    6. next: only ipad1 with audiobus and loopy and loopy hd.

    after some time loopy and loopy hd start crackling/distorting and sometimes pitch up the audio.
    i played back some pre recorded drum loops and added new recordings. when i plugged in and out a headphone (ipad headphone out) sometimes everything went fine...
    for some minutes. then i tested everything without loopy but with the other apps (see above) and found that there was no problem. as soon as loopy/hd is involved i get distortion etc.

    i thought i should report this immediately.

  • Thanks, @owi - I'll look into this shortly.

  • edited March 2016

    @owi - some questions; you mentioned you were using Loopy and Loopy HD simultaneously. Can you reproduce this with a more simple setup? What about with, say, just Fugue Machine and Loopy HD? What about Loopy HD on its own? What about Loopy HD and another app, but without Link enabled? What kind of crackling/distortion are we talking about - is it occasional glitches? Continuous noise? Any chance of getting a recording of this?

  • ok, @Michael, i´ll start working on this soon.

  • owiowi
    edited March 2016

    @Michael,
    first i connected both ipads to ica4+ (audiobus/loopy hd/audioshare).
    when i had link on i could produce the distorted sound after few minutes. when link was disabled everything went fine for about half an hour of playing back the files.
    i sent you pictures and two recordings with pm.
    should i do more testing or is this ok for now?
    loopy behaves similar with scarlett 18i8 and/or uca202.
    yesterday i restored both ipads from backups i made before updating to 9.3.
    but that didn´t help anything.
    after that when i had both ipads running with loopy hd standalone on each one and link enabled (not connected to an interface/just playing back with the built in speakers) i got some hiss and crackles for some seconds randomly after a while on both ipads.

  • I'm in sync hell with iOS 9.3.1 - same problem I've experienced with 9.2.1 and 9.3

    iPad 4, iPad Air 2, iPhone 6S. Same on all.

    I use external MIDI clock from RC-505 via iConnectAudio4+, FCB1010 for CC bindings.Immediate punch-in and immediate punch-out. Works perfectly with iOS8.

    Problem - immediate punch in/out is not immediate. There's a significant lag before recording starts and also when punching out. Clock sync also breaks. Showstopper!

    I thought this was the latency problem with audio I/O, but if that was fixed this must be something else.

    Hope a solution can be identified.

    Thanks

  • @Diggo can you specify what you mean by significant lag? I've noted increased latency of late but it still feels like latency rather than a lag.

  • This is like a full second. I hit the button on the FCB1010, but Loopy takes a second or more before starting recording. Punch out is same, and sync is all over place. Completely unusable.

    Doesnt happen with pre-iOS 9.x.

    After Michael fixed some MIDI clock-related issues, Loopy has been rock solid for me for 7 months. But not on devices using iOS9.x

    I need to try loading an older release of Loopy, see if it's an issue which has been caused by a recent iteration of Loopy which fixed a problem, but created an unintentional consequence in iOS9.x.

  • edited April 2016

    I need to try loading an older release of Loopy, see if it's an issue which has been caused by a recent iteration of Loopy which fixed a problem, but created an unintentional consequence in iOS9.x.

    Except, I don't think it's possible to revert to an older build of Loopy in iOS9.x

    I'm feeling out of the loop but boxed in at the same time!

  • I managed to revert to Loopy 1.4.20, so I'll test etc....

  • Reverting to Loopy 1.4.20 didnt help :(

  • Hmmmmm, seems I might be making flawed conclusions

    I'm using a Behringer FCB1010 to send CC to Loopy HD on iPad Air 2, iOS 9.3.1

    For testing and as backup, I aso have Loopy on an iPad 2 with iOS 8.3 and on an iPhone 6S (iOs 9.3)

    Interfaces include iConnectAudio4 and iConnectMIDI4+, both with latest firmware.

    Until very recently, all has been working well. Rock solid stable since Sept 2015.

    Recently however, a problem has occurred which causes a lag of approx 1 second before punch in commences when I punch in to record a loop. The same lag also occurs when punching out. I dont use pre-roll - I use immediate punch in and immediate punch out. The lag is a showstopper problem.

    Two things have significantly changed - I've swapped an iPad4 for an iPad Air2, and I've upgraded from iOS 8.3 to iOS 9.3.1

    I'm using Loopy 1.5.3

    MIDI Clock is working fine. The lag occurs when using external or internal MIDI clock i.e. it doesnt seem related to MIDI Clock.

    I assumed the lag problem was the (now fixed in 9.3.1?) known latency issue related to iOS9.x, but after further testing it seems related to a lag in receiving the MIDI CC rather than an audio latency problem. If I engage record via the touchscreen, no lag results.

    I'm starting to suspect something has gone awry with the FCB1010.

    The FCB1010 has been rock solid for at least two years, so it didnt initially occur to me that the FCB1010 might be the culprit. I'm now wondering if I misdiagnosed the situation.

    My question: has anyone here experienced a problem with the FCB1010 which manifests as a lag before a CC is processed by a connected device?

    Thanks!

  • After more work on this, I've confirmed the FCB1010 is working correctly. Using Loopy 1.4.20 on iOS 8.3 works perfectly. Using Loopy 1.4.20 on iOS 9.3.1 doesnt work.
    So I've concluded (for now) that the issue is the infamous 1 second lag caused by iOS 9.x, which also means the issue remains unfixed in iOS 9.3.1 when using Loopy. This is really a showstopper problem.

  • @Diggo - I'm getting into this today. Bit baffled right now - I can't reproduce this on my iPad Air 2/iOS 9.3.1 with my Arturia Beatstep (proof! https://www.dropbox.com/s/2s6u2iv32tyazsz/IMG_1096.mov?dl=0)

    Can you reproduce this with any other apps, like MIDI Monitor?

    Clock sync also breaks

    Incoming, outgoing or both? Can you reproduce with other apps?

  • owiowi
    edited April 2016

    @michael - yesterday i did a test: only one air1, ios 9.3, iconnect audio 4+ = input 1 mic and 2 guitar, kmi softstep2=sending note on to loopy hd 1 .5.3/loppy 2.6.3 bindings, audiobus, audiobus remote, loopy hd, loopy, drumjam,
    link disabled in all apps, clock sync enabled, loopy hd= master.
    recording long tracks and playing back pre recorded drumloops with loopy hd and playing back drumloops with loopy went very well.
    you remember my posting above regarding distortion and sync failure with link on?
    to me everything seemed to be ok when link was disabled yesterday.
    tonight i will test midi sync with two air1, ios 9.3, audiobus, loopy hd, loopy, drumjam.

  • Hey @owi - thanks for the update! I have good news: I managed to reproduce the problem on my end yesterday, and found a fix. Turns out it's a bug in the Link SDK, but I've found a way to mitigate the problem. Take a look at the Loopy beta version I just released on TestFlight, and do let me know how you go.

  • thank you so much, @Michael,
    your are the best ever and i hope you will be in touch with all loopy friends forever...
    is it ok to update to ios 9.3.1 for loopy to work (i´m on 9.3) or should i wait till we all tested the new release of loopy hd?

  • Thank you =)

    Yeah, I think that's going to be okay - it's a fairly limited change, as far as I know, only fixes that Safari link bug.

  • thanks for this.
    i´m just testing the new beta. i´ll report what´s going on.

  • @Michael
    air1 ios 9.3, ica4+, input1 mic, kmi softstep 2=note on for bindings in loopy hd, audiobus 2.3.4,
    ab system input 1 (mic) > loopy hd 1.5.4 (beta), ab input patterning> system output, ab input fugue machine > system output, ab remote.
    all apps are synced via ableton link.
    now the apps are running about an hour without problems.
    i recorded in loopy hd long tracks and played back pre recorded drumtracks.
    everything seems to be ok so far.

    before that i tried to sync with the other ipad via link ( loopy hd 1.5.3) but that didn´t work.
    the ipad with the older loopy hd went into distotion and lost sync.

    now i will wait for the update (1.5.4) to update loopy on the other ipad.

    thanks again for helping so fast.

  • edited April 2016

    Great news! Thanks for testing that out.

  • Hi Michael,
    I've loaned my Air 2 with iOS 9.3.1, so cant immediately test the 1 sec punch in latency for instant record, instant stop record (instant punch-in and instant punch-out) but will test asap.

  • Sorry to say the 1 second lag when using instant punch-in/punch-out is still broken in beta 1.5.4 when using iPhone 6S with iOS 9.3

    Will update to the phone to iOS 9.3.1 to see if that helps

  • Thanks, @Diggo.

    Can you reproduce this with any other apps, like MIDI Monitor?

    Clock sync also breaks

    Incoming, outgoing or both? Can you reproduce with other apps?

  • I've now tried 1.5.4 with iOS 9.3.1 but no improvement. I havent tried other recording apps apps except Tonestack, which works fine with FCB1010 and iOS 9.3.1. No latency issue, IOW. I think this issue is unique to Loopy.
    The status of Ableton Link makes no difference.
    Clock sync is fine but once the gap occurs the loop position gets rotated out of whack.

    I dont know if this is a MIDI issue or audio issue.
    What should I look for in MIDI Monitor?

    All works perfectly in iOS 8.3

    Havent tried Loopy 1.5.4 in iOS 8.3 yet, but will do that later today if I get time,

  • I should add: the problem doesnt occur when using Loopy in touch mode (ie without a MIDI input controller), which makes me suspect bindings and/or MIDI PC/CC actions could be involved

Sign In or Register to comment.