Loopy and DrumJam Sync

Hi, I've posted this over on the drumjam forum as well, but no answer yet..

So, regarding Loopy and DrumJam sync:
I'm sure I've had this working before but it's not working now and it's really confusing!

I've tried just about every combination of settings I can think of in Loopy and Drumjam and the tempos are not synced.
I am using Audiobus.
I would like to know what settings are needed for having Drumjam send clock to Loopy and also the other way around, for different scenarios.
I realise that connection is supposed to happen in one direction at a time (and have tried both)

So, in Loopy the options are:
Midi Sync: ON
Clock Source: Link active appears deselected
Clock Destinations:
Enable Network: ON
Virtual Midi: Deselected
DrumJam: Selected

In DrumJam
Midi Settings
Channels: Omni in, 1 out
Send clock even when stopped: ON
Input Connections: Loopy, Network Session clock inputs: both deselected
Output Connections: Loopy, Network Session clock outputs: both deselected
Send midi clock: ON
Allow Connections: ON

What settings would I need to start Loopy's transport at host tempo by pressing play in DrumJam?
What settings would I need to set Drumjam's tempo from Loopy's transport?

And.......

Just wondering if anyone has any thoughts on the upcoming iPad Air 3.
I'm using an RME Babyface Pro, originally bought for excellent quality, portability, flexibility and rock solid drivers.
I am finding that latency is a bit of an issue at 256 samples. If I try 128 it gets scratchy and choppy! Is it possible this may get fixed in upcoming versions of Audiobus, or is it a limitation of iOS itself? Maybe I should ask this in the Audiobus forum but Loopy is my main app and I guess other loopers may have these questions too, especially for live sets!

Thanks x

Comments

  • Bump! Can anyone help with this?
    I tried a suggestion:
    in loopy: settings>clock sync (midi sync=on)>clock destinations>drum jam (check),
    in drum jam: settings>midi setup>in channel 1/input connections>loopy hd=clock input (check).
    then loopy is midi master (starts and stops drumjam, sets tempo for both apps).

    It isnt working :(

  • hi,
    you should make a setting in just one direction in both apps. either loopy or drumjam is master.

  • edited February 2016

    @optimyst - It works on my system with the current versions. Below is the minimum configuration I found that worked. Loopy and DrumJam as AB Inputs, System Audio as Output, 1 route. I saved as a Preset and it didn't work until I kicked DJ out of AB and brought it back in. I think Loopy needs to be running before DJ opens, or as noted below, the Input Connection for Loopy Clock is not available. So when you get it working and save as a Preset, Launch Loopy before DrumJam and everything seems to be fine. An added note, if you can't play the pads in DJ or Start/Stop the loop in DJ, then kick it out of AB, close it and bring it back into the AB route. You can Start/Stop Loopy and DJ together from Loopy or on the AB Panel of AB or Loopy.

    In Loopy

    Midi Sync: ON
    -Clock Source:
    -->Virtual MIDI <----if "Inter-App Audio Sync" is On further down, then it is dimmed
    --Enable Network On/Off <---OFF unless you are using wifi for MIDI
    ---Virtual MID <----this needs to be selected (not selectable if IAA Sync or Ableton Link is selected below!!!!!)

    -Clock Destinations:
    --Enable Network: OFF <-----OFF. again if you aren't using wifi MIDI, for this, no need
    ---Virtual Midi: <----this needs to be selected

    Inter-App Audio Sync On/Off <--- Recommend OFF

    Ableton Link Enable/Disable <-- to keep it simple leave this disabled (If enabled then Clock Source and Inter-App Audio Sync are disabled above. - but it still works sometimes)

    In DrumJam

    Settings > Options:
    -Use Interapp Sync

    Settings > MIDI:
    -Input Connections
    --Loopy
    ---Note Input
    ---Clock Input <------------------------***** This ON, all the rest OFF (obviously you need Loopy running before DJ)
    -Output Connections
    --Loopy
    ---Note Output
    ---Clock Output
    -Virtual MIDI:
    --Send MIDI Clock
    --Allow Connections
    -Wireless Midi
    --Enable Network Session

  • Brilliant thanks I will try this.

    On the drumjam forum I got this answer too..
    "Anyway, ableton Link support will be another option coming in a week or so!"

  • Amazing, that works!
    I didnt even think of putting loopy and dj as AB.
    And yes I did have to restart them after changing settings.
    Thanks for the clear instructions ganthofer.
    And hopefully Link will make all this easier soon!

  • @optimyst - they will also sync out side of AB with those settings, at least they did for me.

  • Yes I need to get a working system for various apps too!
    Just been trying out AUM with mixed success. DrumJam is crashing at the moment when used within AUM.

  • edited March 2016

    I'm still finding there are issues with Loopy's sync.
    It works in AUM but is very choppy indeed. The visual marker is also very jerky with the audio.

    As a general feedback for developers of audio apps, I am finding that the whole sync thing is way too confusing.
    Each app has its own settings for midi sync, clock destinations (with virtual midi and other individual apps) and ableton link, and each app seems to do it differently.

    In Loopy I have IAA sync on and ableton link off, clock destinations set to none. It works, but horribly.
    When I switch inter app audio sync off once the AUM clock is running it sounds fine, so I guess that's narrowing it down.
    Maybe a bug in Loopy's IAA?

    Also a bug where sometimes the transport appears at the top of the screen, which only happens when used with other apps.

  • Yeah, sync is awful =/ We're heavily pushing Link, so hopefully it'll be really simple soon.

    I have discovered a playback bug which is coming in the next version - it might be worth trying the TestFlight build to see if it still has the issue you describe: http://loopyapp.com/testing

  • Thanks, I signed up for testflight.
    I am also currently getting random pops even using Loopy standalone, at 256 frames.
    I shut down all other apps. It seems quite random. I can record a couple of tracks, and then there is one nasty dropout appearing again in each pass.
    I tried:
    Changing power strip
    Doing a reset before every change (shut down and then hold home button to kill 'zombie' apps)
    Changing from 128, 256, 512 each time.
    Using both Audiobus as host and only Loopy.
    512 does seem (mostly) ok but even 256 latency is pretty unusable for live monitoring.
    This is on an iPhone 5s. However, recordings I've done using the earbuds are fine.
    Sometimes I've had Loopy + Push and Dub running through Audiobus at 128 and that's been fine.
    My babyface Pro is running in class compliant mode.

    Could this be a bug?
    Could it be something to do with only having 4gb storage available out of 16gb?

  • Oh, and as to the original post, Drumjam and Loopy are working over Link now.
    The Drumjam developer was very helpful, also offered a testflight and the update is working great now :)
    Link is so much better and easier!!

  • iPhone seems to need to be in airplane mode, as far as I can tell it's behaving now.

  • Interesting - are you on iOS 9? We've heard a number of reports of audio interface wackiness on 9.2 in particular. Apparently at least some of this is meant to be better in the 9.3 beta, but time will tell.

    Glad Drumjam's working better! Are you finding things more solid generally with the latest Loopy update (aside from the glitches, which may be an iOS thing)?

  • Yes it does seem to be something happening only when connected to the Babyface Pro.
    I'm on 9.2.1
    I will keep testing but as long as I can get it stable I dont mind switching into airplane mode, and so far 128 samples is possible which is good enough :)
    Things do seem more solid yes. Link is infinitely better too. So happy to not be going into midi preferences and messing about with stuff I dont understand!
    I will keep updating, especially when using more apps with AUM etc. I am guessing that maybe iOS checking for updates in the background with connectivity apps could have been causing the dropouts with a simple setup.

  • Ok, so I've just done a session with asynchronous loops and the dropouts are happening again.
    iPhone in airplane mode, all other apps closed, running through Audiobus (necessary to get a stereo monitor of my microphone since Babyface appears on only one channel).
    Because these are long loops it was difficult to tell if any of the dropouts are actually on the recordings rather than on playback randomly. I'm pretty sure they are now randomly on playback.

    I also found a bug where a long asynchonous loop behaved strangely with overdub.
    For that track I had added a reverb in Audiobus (empty slot up to that point).
    On one of the tracks (11) it went blue after one touch (but was still overdubbing).
    Also, I started recording on track 12 and it overdubbed to track 11!
    Very strange..
    This was for a sound journey session so the loops are up to a few minutes each.

    After unplugging the CCK from my interface and listening through the headphones at the iPhone I was still getting some dropouts but not as many. I quit Audiobus and reverb but they were still happening.

    Now I've rebooted, listening to Loopy without Audiobus and playback sounds fine, maybe one pop randomly every couple of minutes.

  • iOS update seems to have fixed these glitches for now :)

Sign In or Register to comment.