Latency Problem

I'm having a really bad latency issue. I'm running Loopy HD and Audiobus on iPad Air 2, running vocals and guitar through a Tascam US-800 audio interface using Apple's camera usb adaptor. I've tried all the solutions I've read so far but no luck. Seems to be working fine when I record using Apple headphones. Setting up Audiobus or changing latency setting in either app doesnt fix the problem. Running other apps through Audiobus is all good as well. I'm mildly obsessed with Loopy right now so I really need a fix here. I would like to start using loopy in my live shows if I can get it to reliably work. Michael, if you have any advice I would greatly appreciate it. This app has become an integral part of my song writing. Thanks and great work!

Comments

  • Hey @joeduff. I've just done some digging around this, and turned up some rather bad news. If you're seeing what I'm seeing here, then it's an iOS 9.2 bug that apparently affects almost all USB audio devices. It certainly affects my Focusrite 6i6 - there's about a second of output latency with all apps I tried except for GarageBand and Multitrack DAW, which have probably accidentally avoided whatever sequence of interactions cause the issue.

    Apple have been told about it, so I guess it's a matter of waiting.

    Some resources:

    If, on the other hand, you're not on iOS 9.2 and seeing something different to what I describe, let me know and we'll dig further.

    Best,
    Michael

  • Thanks a lot for getting back to me, Michael. I'm actually glad that it's not specific to my iPad. I will wait it out for now.

    Take care!

    joe

  • Really glad to see this before updating, which I was in the process of starting when I read it! Does the trick I've had to use on my iPad Air 2 with my focusrite work where you start loopy (or other program that uses it), plug it in, kill the app, unplug it and then start over work? I have had to do this every time after the ipad reboots since I started using it.

  • Sorry about the delay, @panmanphil, I didn't see your reply - no, that trick doesn't work with this issue. Worked in the past, but no longer!

Sign In or Register to comment.