Latency problem with Audiobus and Loopy

Not sure if this is an Audiobus or a Loopy problem...

I use a Focusrite iTrack Dock running Loopy in the output of an Audiobus channel with live input. Whenever I run an effects app in the effects slot, any live recorded loops are always slightly out of sync. I've tried this with Echopad, Crystalline, Flux:FX and various latency settings.

To test and verify this, I've recorded the Loopy metronome back through a mic into Loopy. With nothing in the effects slot of Audiobus, it all works fine with no delay or latency. As soon as I put an effects app in (even if bypassed), the recorded latency is immediately noticeable. I'm running iOS 9.2 on an iPad Air 2.

Comments

  • edited January 2016

    Hey @Alan - ah, yes; this is an irritating limitation in Inter-App Audio, the technology from Apple which we (at Audiobus) were forced to use instead of our own protocol when iOS 8 landed. Still haven't found a decent solution to this, unfortunately, but it's greatly exacerbated by the iPad Air 2 in certain configurations, namely when recording through the device's microphone. I've found it's improved a lot when using an external digital audio interface, which doesn't suffer from the latency problems of the iPad Air 2's own hardware.

Sign In or Register to comment.