New recordings beginning in middle of loop

So how do I stop this happening.

• I record a loop that's 4 bars.
• I record another loop on a different track that's 16 bars.
• I go to another track and record yet another loop, this one also 16 bars. But because I press record on bar 4 of the loop, it begins recording my 16bars half way through the previous 16 bars (on bar 8)

Is there a way to stop this happening?
it's quite possible i'm misunderstanding something.

Comments

  • @james948 - one guess is that you clock is still set the same as when you recorded you first 4 bar loop and sync is on.

    A little more info might help in clarifying.

    What are your Track Management > Synchronization settings?

    How are you setting tempo and time sig? Manually or set by first track?

    Are you changing the clock ( 4x from start - 4 bars to 16 bars) ?

  • Thanks!

    Synchronize Tracks: ON
    Count in recording: ON
    Count-in quantize - 2 bars
    Count out recording Enabled
    Count in/out mute OFF

    I've set the tempo manually and I've set the tempo by the first track; though when I've set it by the first track, I've got the click turned off.

    And I've changed the clock and not changed the clock. But it makes no difference that I can see; it's not that it's coming in on the wrong beat; it's just coming in on the wrong bar.

  • Hey @james948 - I just tried to do this on my end so I could figure it out, and I realised I couldn't actually work out how you're doing it with count-in and out enabled; would you give me a blow-by-blow?

    Here's what I'm seeing: with the same settings as yours, Loopy always starts the track at the 0 position (at 12 o'clock). In order to start at a different time, one needs to abort the count-in and tap to begin recording immediately at that point. Then it'll continue recording until tapped again. So,

    1. I recorded the first 4 bars,
    2. hit "x" 4 times to get to 16,
    3. recorded the next 16 with the count-in, then
    4. started the final 16 bars, offset by 4, by tapping to count-in and waiting 4 bars then tapping to begin immediately
    5. punched out after 16 bars.

    That seemed all good, though.

  • This is exactly the problem I have. Maybe is a little more clear with this situation.

    Record A section of song, 12 bars. 
    select next track to record B section for 8 bars (actually haven't worked out the midi to do this either)
    mute B section and play A

    A is now at bar 9. poof

    Today I'll experiment with having track sync off but suspect this won't solve the problem unless it implies starting over at the start of the track. 
    Also I'll experiment with a midi switch to reset right after unmuting. I am using Midi Bridge to do these more advanced footswitch dances but have not come up with a clean way to do this where I don't need a bank of switches for each song. 
Sign In or Register to comment.