MIDI Clock trouble

I used to use Loopy as a rock solid reference for iOS development with MIDI Clock in/out, but now that I upgraded to iOS 9, things seem to be broken. Anytime I subject Loopy to external MIDI Clock now, it initially emits some noise, then hogs the CPU and is quite unresponsive. Is this a known issue or am I doing sth wrong?
However, Loopy works well as clock master.

Comments

  • Hey @Stenzel - hmm, that's troubling. No, definitely not a known issue; it works on my iPad Air 2 and iPhone 6s Plus with an Arturia Beatstep. Can you tell me more about your setup?

    It might be interesting to hook you up with The Spectacular Sync Engine to take its test app for a spin too, if you're willing (I'll need your github username).

  • I've got some strange things using loopy hd with midi sync. Master was either DM1 or MoDrum. I've connected two iOS Devices to iConnectAUDIO4+. On one device DM1 as the master-clock-engine on the other device Patterning as slave worked fine. But as soon as I've started Loopy HD on the second device, after about 10 min. both Apps on the second device were delayed. After shooting down Loopy HD, everything was working fine again. Both devices are on iOS 9.0.2. I've tried the same thing the other way round and also with other devices.

  • And if I use Loopy HD as Master. The Output is not stable. e.g. I start with 132 PBM. The Slave starts with 134 then it goes to 132 and then to 133 in a few seconds. And then it stays on 133 BPM but Loopy HD has still 133.

  • Boo, that's frustrating. I've put an item on my todo list to look into this, @stgisler.

  • edited October 2015

    Thanks! But,

    another strange thing with Loopy HD. After about 10min. playing I get a long latency in music apps. But only if Loopy HD is running too. After shotdown Loopy HD, immediately everything is fine again. I'v got the same problem on an iPad Air 1 (iOS 9.1) and iPod touch 6g (iOS 9.1).

  • Whoa. Do you mean a long playthrough latency? (as in, microphone-to-speaker?)

Sign In or Register to comment.