Why isn't my setup working? (Annotated picture included)

I just started using Loopy and recently purchased what I think is the right equipment to get started. I set this up according to what I've seen on YouTube and Google searches, though it doesn't work. Loopy runs on the iPhone but doesn't interface with the mixer at all (though the phone is receiving power and can communicate to the computer through the USB hub). Please take a look at the annotated picture and let me know what I'm missing. Thanks in advance for helping a new member to the Loopy community!

Comments

  • ah wow, this looks excellent!

    Good news is you have most of what you need. First of all, what is the Mac doing in your setup? Is it just there to provide power, or are you trying to incorporate it into your audio signal chain? I'm going to assume you were just using the mac to try to power your USB hub.

    Here's what you need:

    -- a Powered usb hub that actually plugs into the wall for power. see this one: http://amzn.com/B00DQFGH80 I don't think your USB hub has power cable going into it

    -- a Lightning to USB adapter - this tricks the iPhone into becoming a "host computer" for peripherals such as memory cards, flash drives, digital cameras, and... yep, digital audio devices like the UCA202. http://www.bhphotovideo.com/c/product/897273-REG/Apple_md821zm_a_LIGHTNING_TO_USB_CAMERA.html

    Then:

    1. -switch out your USB hub with one that plugs into the wall. Plug it in.

    2. -put the black cable of the USB hub into the Lightning to USB adapter.

    3. -plug the Lightning to USB adapter into your iPhone.

    That should do it. Always, force close all your other apps and open up Loopy HD before you connect the Lightning to USB adapter.

  • Thanks so much for your comprehensive reply! Yes, the 2011 Macbook Air is just for power. I actually bought the exact model that you linked, but for some reason that didn't power the UCA202, or at least it didn't turn on the power light. Any idea why that might be? The UCA will turn on if I plug it into a computer's USB port. I would prefer to not use the computer for power, but is it okay to do so?

    I didn't know about the trick of using the lightning to USB adapter, so I will purchase one now (and a male-male usb cable I'm assuming).

    Thanks again!

  • No worries. You've got to follow what I wrote ^^ step by step. A male-to-male USB cable will not work. The USB hub's host connector goes into the Lightning adapter.

    Also, you might be able to go straight from UCA202 >> lightning USB adapter >> iPhone. I'm not sure if the UCA really needs a powered hub at all. If not, this would be a much easier solution.

  • It doesn't. I used it all the time to connect my ipad to Studio Monitors without a hub.

  • So I followed your instructions, but it looks like the UCA202 still won't get powered by a USB hub that isn't being powered by a computer. Any idea why? Also, the lightning to USB adapter won't work for iPhones. Will something like this work, or does it need to be a camera adapter?

    http://www.amazon.com/Certified-iXCC-Lightning-Adapter-iPhone/dp/B00SZH730K/ref=sr_1_sc_2?s=pc&ie=UTF8&qid=1441761136&sr=1-2-spell&keywords=apple+lightning+to+usbadapter+iphone

    Many thanks again for your help!

  • edited September 2015

    Oh yep, sorry, that adapter won't do the job, it's got to be the actual deal from Apple or it won't make the iPad work as a host for USB devices. There are loads of non-apple products that you could try, but they just won't work from what I hear. There really isn't any way around spending the $30 on the real thing.

  • Hey everyone, a quick update:

    I bought an iPad and got it to work with all the equipment by using the camera kit, however the sound quality coming out of it is awful and I'm not sure why. I'm using a mono output to the Stero Aux Returns socket and mono input to the Aux Sends socket. This is the only configuration I've found that works. I've included a quick picture.

    Does anyone know what I need to do to fix this? Many thanks in advance for helping a newbie.

  • try to go stereo out uca 202 into the stereo aux return xenyx 1204 or into (stereo) line input xenyx 1204 (then you should not open the aux channel of that input to avoid audio feedback).

  • Hi, thanks for the information. I will try that - hopefully this will be the final piece!

  • edited October 2015

    (Forum double posted my most recent comment, so I'm editing the second one by removing all the text that would be here)

  • Hi again,

    So I tried doing what owi suggested. The output works, but now I can't open the input channel or else I get audio feedback (like owi said). So how do I get input from the Xenyx into loopy if I can't open the input channel? I would prefer to have the mic go through the mixer.

    Or, can anyone direct me to a good resource for how to set up loopy with external hardware? I haven't been able to find a good guide. If it doesn't exist then I plan on creating a tutorial on Instructables.com when this is all up and running.

    Also, I tried something a little different. I plugged a stereo audio adapter (pictured) into the camera connection kit, which eliminates the need for the UCA 202 and USB hub. Seems to work, except I still have the zero input/ audio feedback issue.

    Many thanks to the community again!

  • Welcome to the wonky IOS world!

    Buying the original Apple CCk could save you a lot of trouble. I remember solving a bunch while fiddling with my old battery powered rig. 30$ seems overpriced but it is not if once you find you are saving on painkillers for your headaches!

  • @RhymesWithPants said:
    So how do I get input from the Xenyx into loopy...?

    I'm just catching up on this thread. I may be missing part of the conversation but ...that Behringer 1204 has digital output, no? (a printer style USB port on the back). Just plug a printer cable between the Xenyx and the Lightning to Camera adapter and you should be good to go! that will take all inputs from the Xenyx into Loopy before running out to Xenyx main outputs. Just turn on "monitoring" in Loopy so you also get your live audio going thru to outputs as well as the recorded loops.

    (by the way, iPhone should work too, you just may need the powered USB adapter so the iPhone doesn't think it needs more power)

  • i just tested what @htmx said with a behringer xenyx x2442usb and got these results:
    xenyx usb>cck ipad, inside loopy>monitoring=on, mic>input1/xenyx(main mix), sources(xenyx)=2tr/usb and main mix>phones/contrl room.
    now i could record my voice in loopy and hear what i recorded and what loopy played back.
    but i could not get the signal to the main outputs of xenyx. when i pushed the button ´2tr/usb to main´
    i could not record but only hear the playback.
    recording and signal output simultaniously is only possible when using phones/contrl room output.

  • Hi again,

    First of all, I really appreciate the troubleshooting help. It's been quite a journey!

    I tried plugging the cck ipad directly into the USB port of the xenyx with mic in input 1 and guitar in input 2. Monitoring on in Loopy. At first I had the same issue, so I tried plugging the headphones into the iPad instead of the xenyx. This worked! Just out of curiosity, I tried using the audio adapter setup again + plugging the headphones into the iPad, but this did not work. I also tried fiddling with the 2 track usb buttons, but things only worked if both buttons were off.

    There are still a couple of problems. First, I'd prefer to not have the audio output coming from the iPad. Second, there is some reverb-like effect, but I think that's just caused by a very slight delay in my actual voice vs. my voice through my headphones. It's not perfect, but for now it works.

    I'm also going to try using a Focusrite iTrack. If that works then I'm probably going to return the xenyx and other equipment in exchange for the iTrack, which is less expandable but perhaps a better solution for a beginner. I'll detail the results soon.

  • If I were you I would read up on the Xenyx manual regarding any instructions related to "recording into PC" or similar info. The Xenyx will think the iPad is a computer host so there may be settings you can change.

    From your experiences posted above, it sounds like the Xenyx is routing a stereo feed TO the iPad but not bringing a stereo feed back to the mixer... that would explain why the iPad's headphone port is still active. The iPad is not getting any instructions to turn off its own output and send the audio back to the Xenyx over USB.
    Just some ideas to try...

  • as @htmx said is reading the manual inevitable. i did this but could not find anything about ´recording into pc´.
    then i took my xenyx x2442usb and assumed that this mixer would behave similar to xenyx 1204usb when rercording into the ipad (results see above). the signal (recorded and played back) can only be routed to the monitor section while recording.
    when you only play back from the ipad (no recording into the ipad) you can route the signal to the main mix (in xenyx).

  • Thanks again for all of your help. After 6+ weeks of tinkering with the Xenyx, I eventually decided to just use a Focusrite iTrack, which worked without issue. Hopefully this thread will be helpful to another person who is trying a similar set up in the future.

Sign In or Register to comment.