Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has been closed down.

Can I connect a lightning to micro usb adapter for my audio interface on the iPad?

Hi everyone,

I just can't seem to get it to work.
Focusrite 2i2, powered USB adapter, lightning to micro USB adapter.
1: Do I need a lightning to USB or does lightning to micro USB also work.
The green USB light on the focusrite is not lit, so that probably means it doesn't work with the micro usb :-(.

2: Where in Loopy does the device pop-up, in Settings/MIDI ?


  • That adapter you have is a sync/ charge adapter which only lets you connect your iPad to chargers and computers.

    What you actually need is the "lightning to USB camera adapter" which allows the iPad/ iPhone to be the "host" and your 2i2 will work.

  • edited March 2015

    Ok, thank you very much for the comment.

    Today I received a CCK.
    I plugged the 2i2 into a powered usb hub, a usb -usb cable into another port of that hub with the other end connected to the CCK: nothing.. what am I doing wrong???
    I get no green light on the AI and Loopy doesn't see it either.

    And, when everything finally will be ok, do I then go to the Midi settings in Loopy and enable that network, so Loopy sees it's there?
    I can find this basic information anyhere on the forum.

  • @Swingsis said:
    And, when everything finally will be ok, do I then go to the Midi settings in Loopy and enable that network, so Loopy sees it's there?

    loopy sees the midi connection. you have to enable that port by clicking on that connection. now you´ll see a checkmark.
    please look at the attachment. that might describe the cck connection better than i could do it with words.

  • the usb hub has several ´inputs´ and only one output. this ´output ´ you have to plug into the cck...

  • edited March 2015

    The "host" port on a USB hub is the one that normally plugs into your computer. This one must be plugged into the CCK to the iPad. If you post a picture we may be able to confirm you have it plugged in correctly.

    I always plug mine in this order:

    1. power to USB hub.
    2. connect USB hub with cable to 2i2
    3. close all apps and open Loopy HD
    4. connect CCK to USB hub as host.
    5. connect CCK to iPad
  • Yes! It was the order of connecting.. thank you!

    The thing now is that it keeps searching for the host, so something is still wrong?

  • edited March 2015

    Ah, good question. No, as long as the audio is going thru, then nothing is wrong. That settings page you posted a picture of is just for MIDI data.

    The settings for audio look like this (orange section on right) when the 2i2 is plugged in. You can choose whether it records one or both audio inputs from the 2i2. (Channel 1 for Left and channel 2 is Right)


  • edited March 2015

    Then I am afraid that the lovely (...) ipad still can't see the 2i2 because when I scroll the different tabs of that right bar, that one doesn't show up.

    Needs the ipad a particular setting?

    Or could it be the (probably) China made CCK..

  • edited March 2015

    Right, I see your CCK isn't the official Apple CCK. That is very likely the problem.

    I have not heard of those 3rd-party CCKs working for audio. Or if they do work, then they present problems and are inconsistent. You'll have better results with the Apple CCK (the one in the picture that Owi posted above.)

  • So, I finally got it together ( http://auriaapp.com/forum/viewtopic.php?f=21&t=11150 ).
    I also get the message that this device cannot be used, but in my Loopy menu on the right side, the microphone with the channels as in your picture, doesn't appear.
    I tried phantom powered microphone and a non phantom one, nothing.
    Then I plugged in to the USB hub, a Blue Snowball and yes, that worked!

    So who can help me solve this mystery? (I don't want to use the Snowball of course, it was just for testing).

  • @Swingsis - as Htmx has stated, the non-Apple CCK's (camera connection kit) are very unpredictable/unreliable especially for USB Audio devices.

    There are 2 other possibilities to rule out.

    • 1 - is the 2i2 defective? Have you used it successfully on a Mac/PC? Plugging headphone directly to the 2i2 will get you half way there, but the USB output still needs to be verified, and the best test for that would be connecting it to a Mac/PC.
    • 2 - not all POWERED USB hubs are created equal. Try another brand/type of powered hub. I couldn't find any details on the power requirements for the 2i2, but it is possible that it requires more power than your hub can provide.
  • ´Re: Focusrite Scarlett 2i2. How to be truly mobile.

    Postby BGR » Tue Feb 25, 2014 3:08 am
    My 2i2 was resetting randomly using your recommendations.

    But I changed my mobile phone charger to one that outputs 5V, 2.1A. And the random resets stopped.

    I hope this helps someone else.´

    please see the above copy from the auria discussion board (the link you posted).
    like Ganthofer said, maybe that the 2i2 needs more power.

Sign In or Register to comment.