iPad Air 2 latency :( (Fixed by the awesome devs!)

edited January 2015 in Support and Feedback

Hi guys. So after watching some youtube videos, I decided to jump in on the iPad music bandwagon. I recently purchased an iPad Air 2 and was pretty stoked about it, too.

My first app was Loopy, and I gotta say I'm a bit disappointed. It's pratically unusable as it is. Every time I record I get a few ms of lag when it plays back.

I've recorded a video of a way I found to show it: https://www.youtube.com/watch?v=6xj4eovstyU

I've tried restarting the iPad, closing all the apps and even resetting it (ugh.. :/) and no luck so far. I've also tried with the Apple buds and I get the same result.

Thanks in advance.

«13

Comments

  • Ergh - that's new! Yep, I can reproduce that on my Air 2 here as well. I'm gonna sort this out and get a fix uploaded.

  • Okay, I see what's happening. Fixed in dev version, which is getting close to release-ready.

  • @Michael said:
    Okay, I see what's happening. Fixed in dev version, which is getting close to release-ready.

    Wait.. really? If so, that's the best support ever, huh! Would you be willing to record a video of sorts or something like that?

    I mean, forgive my skepticism, but I find it a bit hard to believe that you can actually perform flawless loops in an iPad without manually adjusting them due to the latency -- but I hope you guys prove me wrong, that's why I bought this app!

    Thanks in advance.

  • edited January 2015

    Haha sure! It was an easy fix. Here you go:

    http://youtu.be/MRfXmlvyKqQ

  • Likey worky loopy.

  • edited January 2015

    @Michael said:
    Haha sure! It was an easy fix. Here you go:

    http://youtu.be/MRfXmlvyKqQ

    Oh. My. God. You guys are the best. How can I buy you a RedBull? Great work, patiently waiting for the official release!

    @Ringleader said:
    Likey worky loopy.

    Worky Loopy indeed!

  • Hehe, thanks for the kind words =) It's my pleasure!

    Will try to get this bad boy out soon. Very sorry it spoiled your first iPad experience, I feel quite guilty!

  • OP here (can't get into my account)!

    Will try to get this bad boy out soon. Very sorry it spoiled your first iPad experience, I feel quite guilty!

    Any chance you could hotfix at least this issue? It's been almost a week and I still can't use the app, I'd be really grateful for a quick patch! :(

  • It's still in development, but I'll investigate getting Loopy going with Apple's new TestFlight system so you can get access to a prerelease.

  • There you go. Check your email.

  • Hi! I'm running loopy HD on an Ipad air 2 64gb, and I'm having the latency issue described and demonstrated here. I'm atm using the internal mic (haven't got a lightning cable for my apogee mic yet). Help? :)

    • love the app, btw! :)
  • http://loopyapp.com/testing/ if you wanna give the prerelease a try =)

  • ah, the fix isn't out yet, I thought I might have missed something since the last posts were in January. anyway - filled in my email :) thanks for the quick reply and AWESOME work with the app!

  • Yeah, this has been the longest update cycle ever! Lots of careful tweaking in this one, it's taken a while to sort out. Nearly there now.

  • Oh, and thank you!

  • This is exactly the problem I'm having on my ipad air 2, a delay on every track. Was this fixed released? I am running 1.4.11 right now.

  • It should've been fixed in 1.4.11! Any chance you could hook me up with a recording of the issue?

  • I will try, yes, just haven't done that before. I'm thinking I can plug the mac in to the same usb hub the usb to lightening adapter is connected to and record into quicktime from there? short a cable so will run out to do that now .

  • I wasn't able to attach the ipad to the mac through a my usb hub, so couldn't do a screen capture. I saved an mp3 file, but this forum won't let me attach that. What is the best way to get you the file or show you what you need?

    Thanks?

  • Ah - try again; I just tweaked the forum settings.

  • Just two tracks. First one was recorded without setting tempo, just clicked the midi mapped control to start record. When the recording stopped the metronome kicks in and is pretty good. I started a new track and you can hear the delay.

    IOS 8.3
    ipad air 2, 32gb
    loopy 1.4.11

  • Hmm I'm afraid I can't really make much sense of that - could you record something simple? Maybe just yourself saying "one two three four", or clapping, or something.

  • Here is a much simpler version. There is a bit of dead space in the beginning between hitting record and doing the first loop.

  • Hmm, interesting. Just to make sure, that was made with "Live input recording" off, right? What hardware are you using? Have you tried with different hardware, or without hardware at all?

  • Ah! I've just been able to reproduce it with one piece of hardware I have - the Focusrite Scarlett 6i6. Native Instruments Komplete Audio 6 is fine, but the Scarlett shows really high latency at first - unplugging and plugging back in seems to resolve it, but that first time, totally busted. Looks like an iOS or hardware bug, but I found a workaround. If you'd like, try the beta.

  • Correct, live input recording is off. Unplugging it and plugging back in. well that might explain why it would occasionally work perfectly, but that hadn't happened for awhile now! I will try the beta

  • The beta seemed to be working. But after a power off and power on of the ipad, the first still has the delay in my case. thanks for the suggestion of unplugging and plugging back in the focusrite, from then on it work perfectly.

  • Hmm, that's surprising. Ah, well, good enough for now =)

  • Hiya! I wanted to let u know that iPad Air two is having major input monitoring latency issues when just using it with the internal mic and headphones. I was using it a party last night with a group of musicians after we did a show at hangout fest. I thought I would just plug in some headphones start the loop and pass around the iPad. But the audible latency was too great so we switched to the iPhone 5. Tested it this morning and the iPhone works perfect. iPad is works fine if input monitoring is off. It's odd because when the fix was first declared fixed I remember it being better. Thanks also is there a place for feature requests? MIDI foot controller mute all except the selected track? Mute row? Mute column? I love loopy btw!

    Sent from my iPhone using Tapatalk

  • edited May 2015

    Interesting - what headphones were you using? And cheers =) ('solo' should do what you want for the first; mute row/column's a good idea...hmm)

Sign In or Register to comment.