Mystery MIDI binding issue!

edited October 2014 in Equipment

This is my first post! Looking desperately for some help. I don't seem to find a similar issue in the forum. Here goes:

I am trying to use Loopy HD on the latest iPad Air (IOS 7.1.2) with the Softstep 2 foot controller. I have tried connecting directly to the iPad using the USB lightning cable, and also by connecting a Fireface UCX interface directly to the iPad and connecting the Softstep with its MIDI expander. The issue in both scenarios is this:

Although Loopy DOES see MIDI coming from the Softstep (Programmed to output MIDI notes) in the bindings window and the Softstep port is selected (there is a tick in the control inputs section), any assigned and saved bindings simply do not activate the necessary functions in Loopy!!.

This seems extremely odd as the MIDI notes are getting to Loopy (also MIDI Monitor) as stated above and they are saved and listed in the bindings window. However, the assigned bindings do nothing in Loopy!

I have tried pretty much all I can think of: Rebooting the iPad, re-installing Loopy, making connections in different orders, etc etc. Strangely, I did have it working briefly at one point a while ago!

This has been very very frustrating to say the least. Can anyone help? I can't believe I am the only one having this issue.

I contacted Michael by email about this issue and he was very helpful but even he is at a loss as to the solution of this mystery issue.

I welcome any assistance/clues/tips on this matter as I love Loopy HD!!!

Thanks in advance for any help.

Jojo

Comments

  • There was another KMI Softstep issue http://forum.loopyapp.com/discussion/comment/7705#Comment_7705

    Have you tried using CC's or PC's instead of Note On/Off?

    Do you have another midi controller/keyboard you can try?

  • Thanks @Ganthofer for you response! I will try your suggestions and post back in due course.

  • Thanks again @Ganthofer for your suggestions. It worked!!! Using PCs, everything is working as it should. Very strange though that the MIDI notes route didn't work.

    Your help much appreciated.

    Jojo

  • @Jojo - good to hear you're up and running.

    @Michael - did you ever find out what is going on with the Note On/Off with the KMI Softstep?

  • Not as yet, @Ganthofer - there's a bit of an information drought on the matter right now; nothing has turned up in the diagnostic info, so I'm currently waiting to see if we can get any more data points.

  • maybe there is some kind of keyshift or transposing somewhere.
    some days ago i made bindings in loopy hd with my old sequencer-keyboard (yamaha qy700). i hit key ´e´ on the keyboard and made a binding for ´select track´. the binding was: ´e3 off ch1´. now i put this note value (e3) into a sequence and sent it to loopy from the sequencer. nothing happened. when i set the note-value in the sequence to ´e2´ loopy did respond to this and selcted the next track.

  • owiowi
    edited October 2014

    it must be inside loopy. i sent ´e2´ from ableton live to binding ´e3´ and it worked.
    note_off set to velocity ´0´. when note_off velocity was >0 there was a double trigger.

  • Do you see a 'tick' on the midi device selection? I can bind but not have it active. Try selecting the soft step looking for the small tick. If you know this and what I'm saying is completely stupid just ignore it. Just a problem I had.

Sign In or Register to comment.