Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has been closed down.

SUS record in Loopy HD

edited September 2014 in Support and Feedback

Hi folks,
I'm new to loopy and still kicking its tires to make sure it's right for me.

One thing I'd like to do is toggle record with a note on message and toggle record off with a note off message so that audio is recorded only when I'm pressing down on a note.

While the midi binding seem to allow this in principle, I haven't had any success yet by assigning the note on and off messages to "toggle record".

Any hints? Can this be done with loopy?


  • ok, I did some more testing and if I remove the note on binding and keep only the note off, it's pretty clear what the issue is... The note off binding is activate as soon as I press down on the key... that is the note on will trigger the note off binding.

  • As for the Note On triggering the Note Off binding, I believe there is a post here from @Michael that that was done on purpose. Don't recall the reason. I can reproduce this, but it does not interfere with what you want to do.

    I tried this with an Alesis Q25 keyboard, Griffin Studio Connect, iPad Air (7.1.2),Loopy HD (1.4.10). Note On and Note Off bound to Toggle record. Worked as expected; hold key down and recording starts, let go of key and recording stops. If you press it again, Overdub will be started and stopped. The setting for record count-in/out will affect how both of these react once you tempo is set (after the first recording tempo will be set if you don't explicitly set it).

  • I'm using a KMI 12 step with an iPhone 5. I know it works, since the note on and off messages appear in loopy's binding window and I am able to bind both note on and off to toggle record. However, I do not get the result you describe. Recording starts on note on but does not end with note off.

    I've disabled count-in/count-out, so that shouldn't be the issue here.

  • I have everything under synchronize On/Enable and Count-in quantize = Clock Length. Reset Session ( no recorded tracks and tempo not set )

    Is your Tempo set or unset when you try? Any existing tracks?
    What does happen when you release the switch (Note Off) ?

  • Ok, it's probably something to do with the KMI twelve step since I was able to get the expected behaviour from another controller. It's odd that loopy should recognize the messages on binding, but not when I try to use them...

  • edited September 2014

    As far as I know, there are 2 ways to turn off a Note. A Note On command with velocity 0, or a Note Off command. Might show in Midi Monitor if there is a difference between what your KMI and other controller are sending. Perhaps both are not working in Loopy? I know my FCB only sends Note On velocity 0. I may be able to test sending a Note Off from my PC, probably not until next week.

  • Here's a what the controllers are sending (see attached image). Ch 2 is the controller that works and ch 0 is the twelve step. Only difference I can see is that the 12 step sends note off at zero velocity whereas the other controller sends it at the same velocity as the note on.

    I think you've found my problem...

  • @Michael - please take a look at this when you can.

  • Hi guys - sorry it took me this long to jump in. Weirdness indeed - @spoitras, would you mind going into Help in Loopy, then Feedback/Support, and then tap "Email Support"? This'll send me some diagnostic info that might help to get to the bottom of it.

  • @Michael, sent. Thanks for looking at this.

  • Thanks @spoitras. I'm seeing some weird discrepancies here: firstly, it doesn't look like you've got any device enabled for control input - make sure there's a tick beside the device you want to use, or it won't be active at all. I'm also seeing no bindings saved for the 12 step; only the "Duet USB" device has any bindings saved.

Sign In or Register to comment.