iPad Air latency issues

I'm using an iPad Air with no audio interfase and Loopy HD. I'm having big latency issues trying to record with onboard microphone. I have restarted my iPad and made sure it's the first program I open, still fails...

I have tried GarageBand for iPad and it does not have any latency at all.

Could you please advice what else should I do?.

Comments

  • I have also tried recording thru my apogee jam and latency is the same...

  • Hey Charly - I'm sorry to hear that! Have you got Audiobus? If so, when you launch Loopy, then Audiobus, what does it say in the top-left corner in Audiobus? Conversely, what does it say there when you launch Audiobus, then Loopy?

  • edited July 2014

    Hi Michael... I don' have Audiobus. Would that fix my issue?

  • Ah, righto - no problem, we'll try something else. Firstly: can you describe just what you mean by "latency"? Do you mean playthrough latency - as in, the time it takes for audio to go in the mic and come straight out the speaker? Or are you getting some incorrect time offsets when recording loops?

  • edited July 2014

    By latency I mean that whatever I play, it's delayed by 100 milliseconds approximately when I listen on my headphones. So, when I'm recording following the tempo, the result is not in sync with the tempo.

  • Wow, so it doesn't even get corrected after recording? This is weird, I've not seen this before. I'll look into this.

  • I'm having a bit of trouble figuring this out, @CharlyTesalonica - any chance you could make a recording to demonstrate the problem? Video would be best, but audio would be okay too.

  • @CharlyTesalonica - I have an iPad Air (latest iOS). It is wifi only and I do not have noticeable latency using headphones and the built-in mic. When you say "...restarted my iPad and made sure it's the first program I open, ..." Is it the only program open or are there other Apps that you open after Loopy? And if Yes, what are they?

    @Michael - you would no better than I, what could cause the problem. But I can try on my air if you have ideas as to what settings (Loopy or external) or work flow might be the culprit.

  • I changed my iPad today for a new Air 128gb wifi + cell... Loopy hd is doing the same thing. It's frustrating. Here's what happens;

    No other programs opened... I open loopy hd, connect headphones and I hear whatever the microphone is getting with a noticeable latency. For example, if I clap, I don't hear it immediately on my headphones, it takes something like 100 ms to hear it on the headphones.

    Any recommendations?

  • This may be a stupid question, but the headphones are hardwired. Cable from the headphones to the ipad jack, Yes?

    I have a few ms delay with the built in Mic and headphones. Definitely not any where near 100ms. I'm on an ipad air 64gb wifi iOS 7.1.2 (just updated, but also worked with the previous version) and Loopy HD 1.4.8

  • This is really unusual. to me it sounds like a timing issue.

    At one point the OP said:

    when I'm recording following the tempo, the result is not in sync with the tempo.

    So what tempo is he referring to? Does he have Loopy's metronome going? Or a stock loop going?

  • Also, JB? Or stock iOS?

  • edited July 2014

    IPad Air, ios 7.1.1 - yes there is a little bit of latency. It is like a very short slapback delay. Loopy seems to default to 1024 frames which is going to give a bit of latency (tested by opening loopy first and then opening audiobus and it shows the frames at 1024). Thing is, I never use the monitoring function in loopy because I use direct monitoring on my interface so I cannot verify whether or not it has always been like this.

  • Loopy seems to default to 1024 frames which is going to give a bit of latency

    Wow, that would make a big difference. I always play Loopy within Audiobus, so I've never had this problem.

  • Oh dear! It should be using 256 frames. There's a bugfix release imminent (Loopy waiting for me to flip the switch, Loopy HD still waiting for review). Hopefully that'll fix it, but if not I'll sort it out shortly after

  • Thanks @michael :) hope it'll get fixed it soon!

  • edited July 2014

    Conversely, what does it say there when you launch Audiobus, then Loopy?

    Tried it and it says 1024 then too. So Audiobus/Loopy users should have noticed this too. It's crazy that Loopy has the power to override Audiobus frames settings even when Audiobus is opened first?! All hail Loopy! :-)

    Now this has me inspecting everything. Anyone else notice that Audiobus opens with frames of 220 and then quickly switches to 256? Wonder what that's all about.

  • Thanks for looking into this Michael, great support. I can't wait to start using this awesome app again with headphones

  • I use beyerdynamic dt 770 headphones connected directly to the iPad. I also use loopy's metronome... I've just updated to iOS v7.1.2... I'll test again tonight...

  • Okay, guys, .9 is out (processing for App Store, anyway) - let me know if it fixes the issue or not.

  • I think that the problem of latency is solved! @michael thank youuuu! I'll continue checking it out, to tell you more certain... But for sure I don't listen to it anymore! :) I

  • I've just tested the updated version and it doesn't have the latency issue. This is great support. thank you very much Michael and All.

  • I'm very, very glad to hear that!

  • Likewise. Had a quick play with live monitoring through headphones and no noticeable delays/latency. Great support, thanks very much!

  • edited July 2014

    Thanks @michael !! Great support! No more latency problems on Loopy for Iphone 4S

  • My Looper is having 100 ms slap back as well, I am using a 128 gig iPad air 2. This is with headphones and the internal mic. I have the Apogee duet and I have not tried that yet. But it's kind of impossible to layer percussion sounds at this point. I can manage to get some vocal loops to work if they are melodic but it takes a mental trickery.

  • edited January 2016

    I'm having this latency issue as well. I'm running Loopy HD and Audiobus on iPad Air 2, running vocals and guitar through my Tascam US-800 audio interface using Apple's camera usb adaptor. I've tried all the solutions I've read so far but no luck. Seems to be working fine when I record using Apple headphones. Setting up Audiobus or changing latency setting in either app doesnt fix the problem. Running other apps through Audiobus is all good as well. I'm mildly obsessed with Loopy right now so I really need a fix here. I would like to start using loopy in my live shows if I can get it to reliably work. Michael, if you have any advice I would greatly appreciate it. This app has become an integral part of my song writing. Thanks and great work!

  • I've answered @joeduff's comment on the duplicate thread, over here: https://forum.loopyapp.com/discussion/2864/latency-problem

Sign In or Register to comment.