Hi! If your question relates to Loopy Pro, you may find a faster answer at one of the other Loopy Pro communities (https://loopypro.com/communities) – this forum has only a small number of active users.

MIDI Mapping Behringer FCB1010 - HALP!!

I'm using Loopy with iPad through an Apogee Quartet, and I (am trying to use) the Behringer FCB1010 with it. I've been able to slog through the awful krautiness of the terrible 1010 manual – enough to get a few pedals programmed, anyway.

I've made a preset for pedal 1, and I thought the simplest thing would be to assign a "Note 01 On" value for it, and then bind that to "Toggle Record." Then for pedal 2, I assigned "Note 02 On" and bound it to "Select Next Track."

It works, kind of. It records, but nothing will play. The loop wheels don't turn, but just indicate record, play, and select. Manually pressing the "play" arrow on the touchscreen does nothing. Clearing the session and using just the touchscreen makes everything work as it should.

I suspect this has something to do with there being no "Note XX Off" signal for the corresponding "Note On", but I'm lost. Any help would be really appreciated!


  • edited June 2014

    I don't usually use notes for bindings ( afraid some synth/midi key will accidentally trigger it), but they should work. I know at one time @Michael had done something with the Note On/Off bindings, but I think it was to always bind Note On even if you bound Note Off ( not sure of what actually happens now).

    Do you have other midi apps or hardware running?

    When you look at the midi bindings you made, do they show as Note xx On ?

    Also, use something like Midi monitor (free) to double check what is being sent by the FCB1010.

    If you don't make any progress, let me know and I can't test it once I setup my rig, since I have an FCB1010.

  • Thanks for the reply! I don't have anything running but loopy (and of course Apogee Maestro in background). Yes, the "note XX on" bindings are showing up, and they work to perform the function. It's just that time does not seem to pass; like, the loop shows the record indicate color on one press, and stops recording on the next press. But the spinning indicator doesn't turn, and when I select the next loop (which works just fine on pedal 2 with "note 02 on"), it seems to acquire the length of the original loop, which is zero. The little indicator rabbit just sits there on all loops. It's as though Loopy forgot to press play when recording, as it automatically does when you record by touching.

    What do you prefer to use, rather than note on? I've used MIDI as a player, and have edited it extensively in a DAW, but as far as programming it I know next to nothing. I just used note on because I figured a CC or something has some sort of second expression value Loopy might be waiting for. Though, that is just an assumption.

  • I usually use PC's because the FCB can send 5 per pedal. I usually use the CC's for things that need a value as well, hlike Volume and pan. You do have to be careful, since the FCB can send 8 midi messages per pedal, that you only send the one you want.

    I'll try it over the weekend using notes and see what I get.

    What iPad and iOS version are you using?

    Also, for the first loop, unless you know how long it will be an the tempo, leave the tempo in set ( with synchronize, count-in record and count-out record On). It will start recording when you tap the pedal first time, and end recording when you tap second time. From then on the tempo and clock are set by Loopy to match the first loop. You must set the Clock to the number of measures if you want it to count-out automatically. Turn off count-out record if you want to manually pick the end.

  • Actually, I'm using the iPhone (7.1.1) as my 21mo-old daughter has commandeered the iPad. I find the smaller screen not much of a hindrance, as I plan to control with the pedal anyhow.

    The count-in setup you describe is the default, I believe, yes? In any case that's what I have set. I want to pick the length of the first loop, and have all subsequent loops begin recording at the top of the cycle, in that length or multiples of it. This is the way it works when I use the touch screen with no pedal connected, and it suits me perfectly.

  • OK, I have an iPhone that I'll try also.

  • So using an iPhone 5s, Griffin StudioConnect, 30pin to lightning adapter, I configured Bank 0 pedal 1 for Note 1 Channel 1 and pedal 2 for Note 2 Channel 1, both in airplane mode and regular(cell and wifi enabled). Worked fine. Tried it with midi In only and with both midi In and Out connected. Tried 6 and 12 loop layouts. Also tried another Bank, another channel and tried Notes 0 and 1. All worked fine.

    Two things I would recommend;

    • check what iOS is receiving from the FCB1010 using midi monitor. Loopy only shows you the last sent midi item when making bindings. Midi monitor shows all received in a list.
    • try binding a mother pedal to toggle record ( not pedal 1). Maybe pedal 1 has a defect, but midi monitor should show that.

    Also, what are you using to connect the FCB1010 (5pin din) to the USB midi on the Apogee?

  • Gee thanks! I'll try all this as soon as I get back in the studio.

  • OK, what I've got: iPhone 5, lightning connector, into Quartet, airplane mode both on and off, MIDI input is M-Audio UNO. Programmed Note 01 on pedal 1; still have the problem. MIDI monitor shows CH 1 PC 0 with every pedal 1 press, as well as CH 1 note on, note off, and velocity for both on and off. Should all that other stuff be happening? Behringer manual has no instructions for removing signals from a pedal, just adding them. I can reset to factory values, but this only removes my Note 01 program. Don't know why the other signals would screw up my note, as I have no other bindings. Hm.

  • Tried programming other pedals; no joy.

    And this: whenever I have the FCB plugged in to the Quartet, Loopy exhibits the glitch (recording length = 0) EVEN WHEN I use my fingers to record the loops. If I unplug the FCB, Loopy works as normal.

    MIDI monitor shows no signal coming from the FCB while it's just sitting there, other than, of course, Loopy HD: On and Quartet: On. So if there's no signal, why is it paralyzing my loops?

  • MIDI monitor is saying, rather, "IDI Input Found" for Quartet and Loopy. Nothing is "on" in the sense of a signal.

  • I would expect that midi monitor would also show that there is ID1 for the inputs and outputs for the uno connected. It does for my Griffin connect, but maybe not for a USB midi? Any other midi commands shouldn't matter, since Channel 1 Note 1 On is the only thing bound to Toggle record.

    I have programmed my FCB1010 manually, but usually use FCB Editor on a windows laptop to configure the FCB.

    I don't find anything about the Quartet USB midi as far as if it can power external USB midi devices. Do you have a powered USB hub you could try in between the Quartet and the UNO? Or do you have a CCK that you could directly connect the UNO the the iPhone and use the built in mic and headphones to test?

    I can not reproduce the problem with my hardware, but I don't have an UNO or a Quartet.

  • It seems that the Quartet does power the UNO. Well, the UNO power light is on and MIDI signals are getting back and forth, anyway. It could be the signal is weak, I guess, but the Quartet is powered; I would be pretty aghast to find its USB port non-powered.

    What seems to be happening is that MIDI signals are getting back and forth just fine (again, everything that should happen is happening) it's just that something about the connection to the FCB is paralyzing the loops, regardless of what commands I give to Loopy or how I input them.

    I suppose I should wrestle the iPad away from the baby and see if I have better luck there.

  • AAAAHHH!!! I solved it!

    I had the "MIDI in" connector of the UNO connected to the FCB as well as the out. Disconnecting MIDI in solves the problem.

    Was unsure whether to connect it starting out, as I knew the signal only needed to go one way, but said what the hell. I still don't know quite what happened, but it works now. Thanks so very much for your help, though.

    I do have one more question, though. Loopy seems only able to take two of the Quartet's inputs at a time. I don't know whether that's a hardware limitation or if it's something being worked on. But it doesn't seem to me there is a binding for switching the little domino-looking selectors. Am I wrong? A binding which does this would be a BIG old help.

  • One quick thought, only use the midi out of the FCB1010. Don't connect the midi in.

  • You thought of it before I could respond.

  • edited June 2014

    In theory, it should work with both connected. It does with my setup, but the UNO or the Quartet is maybe echoing the midi back to the FCB and the FCB has midi thru, so any input shows on the output. Doubling the note 1 on causing it to start/stop.

  • edited June 2014

    As for the input selection, Loopy only records stereo. If you want more channels recorded to the stereo loopy track, you could use AudioBus (with the IAP for multi routing) and feed more in (still only recorded to 1 stereo track). If you want more than 2 or more input channels recorded to individual tracks, then you would need a different recording App.

    You are correct, there is no binding to control which input channels are being recorded. This is on the Facebook feature request poll. Have you voted for your most wanted features?

  • Audiobus! Of course! Thanks!

  • Will purchase forthwith; pretty sure that solves it.

Sign In or Register to comment.