Wouldn't an option to "snap" together the starting points of loops make sense?

edited April 2014 in General

I'm fairly new to this app. Here's my problem:

  1. Use Genome MIDI Sequencer through another app with audiobus, recording the resulting rendered audio in Loopy (4 to 6 bars of music). The Midi clock of Genome is aligned with loopy while recording, and works/starts/stops ok.
  2. Save project.
  3. Attempt to do #1 again on different loop of the same project, and now the midi clock doesn't line up with the starting point of the first track I recorded.
  4. Go ahead and record anyway, and attempt to align them after the fact (usually after many trial-and-error adjustments).

Seems like there should be a way to have the two loops "snap-to" each other so the beginning of the loops can be easily aligned after they are recorded. Another (better) option would be to have the midi clock synchronize the new recording with the starting point of the existing loops, so they don't have to be aligned later.

Also the starting point of the loops should be clearly indicated somewhere inside the loop to allow for easier adjustment. After I record the audio, it's often difficult to figure out exactly where the starting point was.

One other thing. When I record the 2nd loop at the same tempo and same number of bars, part of the 2nd loop gets cut-off, don't remember if it's at the beginning or the end. I'm using the count-in feature set to bars.

Thanks

Comments

  • How exactly are you starting/stopping Loopy recording? When you say you are using the "count-in feature set to bars", is it half, quarter, 1, 2, 4, 8 or 16 bars? What is your settings for Count-out record? Does the clock length (moving ring in the menu bar) match the loop marker in the first track, second track?

    In synchronized mode ( using quantize Count-in record) Loopy ALWAYS starts recording at 12:00 (marker at the top of the circle) unless you double tap to start recording immediately. If Count-out record is On, then it will automatically stop based on the Clock setting ( again, at 12:00). If Count-out record is Off, then it will stop based on when you tap it and the quantize setting.

    If you want them to be the same length, I would recommend setting quantize to 'clock length'. Typically, if you have not set your clock length before the first track is recorded, it will be set automatically to the first track length.

  • edited April 2014

    The first midi track consisted of 6 bars. When I hit record, it started recording at the 12:00 position, and then automatically stopped recording after the 6-bar loop ended its cycle in Genome. The second track also consisted of 6 bars, same tempo. I recorded it exactly the same way, but when it was finished part of what should have been recorded was cut off.

    I'll double check all the settings when I get a chance to try it again, including quantize set to 'clock length'. I'm not sure what the exact setting were but I'm pretty sure the count-in was set to 1 bar. If I had started the count-in 1-bar too early, would that explain the cut-off?

  • edited April 2014

    Here is what I think is happening; the first track records fine. Once the first track is recorded, the next track will always start recording at 12:00. The count-in quantize is not going to affect anything with regards to when recording will start. If the loop indicator is at 12:01 or 6:00, the indicator will start flashing when you tap the track to record and will record when it reached 12:00 ( whether it 5.9 bars or 3 bar).

    How (or where) exactly are you triggering Loopy to start recording ( specifically on the second track)? And is Loopy playing ( indicator going around on track 1) or Paused ?

  • quantize set to 'clock length' seems to have done the trick. Not sure what I was doing wrong the first time.

    In any case my original question/problem still stands... Once you save a session and come back to it later, i.e. lose the original clock sync and try to record midi again to it later (see above)

Sign In or Register to comment.