Loopy HD with Bleep Street's Sunrizer

edited May 2012 in Support and Feedback
First, I love this program! I would love to see the ability to sequence loops somehow (or at least the ability to chain midi commands) This issue might be a bug in Sunrizer, Loopy HD or iOS, so I'm posting in all three.

When Loopy is playing the background, and I start Sunrizer, it boots up, but produces no sound until Loopy is quit and Sunrizer is restarted.

I should add that if I start Sunrizer, then start Loopy HD, put Loopy in the background playing a loop and then place Sunrizer in the front, I immediately get an audio buzz, which goes away if I send Sunrize back. (All this with Audio Bkg off)

Another scenario: If I start Sunrizer with Audio Bkg on and put it in the background, it plays fine. When I start Loop HD (with its background mode OFF), I get the audio buzz again.

I also tried this with Cassini and SSSynth in the foreground with Sunrizer in the background and that worked. It looks like it could be Loopy HD issue.

Has anyone had issue with these two apps playing together?

Thx in advance!

Comments

  • Hey @flyboy - Ah, yeah, this should hopefully be fixed in the next update; I've basically rewritten a huge chunk of Loopy to make it much more efficient. I'm pretty optimistic that that'll do the trick.
  • Yippee! I love the combination, so I am happy happy happy! Unless the next update is months away...
  • Nearly done now =)
  • edited July 2012
    Great as it is, the 1.2HD update unfortunately doesn't make Sunrizer work. I've got a strong suspicion that this is Sunrizer's fault, as other soft synths like Animoog or NLog Pro work fine. I found this http://www.wizdommusic.com/GeoSynth/faq.html#sunrizer - but apart from the fact that the trick doesn't work for me, I've got my doubts about the theory. Maybe it's just that Sunrizer insists of being THE single recording app in the system, otherwise it's sulking. @Michael: you being the iOS audio guru, have you got an idea?

    (A pity BTW - Sunrizer is my all-time favourite iPad softsynth so far.)

    Edit: Always wanted to say this: you did a marvellous job with Loopy, and all this while travelling.
  • Sorry about the delay responding - I missed this thread's update!

    Thanks heaps, @untergeek!

    It sounds to me like there is indeed a resource clash between Loopy and Sunrizer - on iOS, only one app can claim the microphone at a time (if it's using the "Recording" audio categories). That means if one app's using it, and you start another, the first app will be stopped.

    I'm just experimenting today with using an alternative audio category type that does not require this one-at-a-time operation - I'm not yet 100% sure it's going to be possible (the main hitch currently seems to be the multi-channel stuff, which doesn't seem to be possible in any other mode but the "Recording" audio categories), but if it is, it should make all the difference.

    I'll have a word with Jaroslaw, Sunrizer's developer, about what he's using - he might be able to start using the plain ol' Media audio category too, which will avoid the problem from his end.

  • That's great. Good to hear that even if my two all-time favourite music apps for iOs don't get along, their creators do... :)

  • Hehe =)

    Incidentally, Jaroslaw tells me the problem is that Sunrizer doesn't like operating with other apps that set a hardware buffer duration (that's latency, basically) other than 512 samples. It'll be fixed in the next update, then hopefully the problem will be solved.

  • I have seen the same thing with Sunrizer and pretty much any other audio app!
    That would make sense if Sunrizer (great sounding as it is) needs a specific audio buffer as this would effectively disable background audio for any other music apps

  • Sunrizer works quite well with iMS-20, BS16i, MoDrum and NLog Pro (if you don't use more than two of them et once, that is... ;)

  • Just to close this thread, I've just installed the recent Sunrizer update. What can I say: with V2.1, Sunrizer works perfect while Loopy is running. And the developer has added a waveshaper and a new bandpass filter for good measure, as well as MIDI sync, so any of you who hasn't got Sunrizer yet, do.

    Thanks Michael so much for discussing the issue with Jaroslaw!

Sign In or Register to comment.